Rons 1060 Terminator

Old 06-30-2009, 06:15 AM
  #11  
hammertime
Senior Member
RACING JUNKIE
 
Join Date: May 2003
Location: Coldwater, MI
Posts: 2,998
Default

Let me know how it goes, I did see a "0" pump on rj if you think thats the fix, but I think its something else. Have you ran with this converter before ?


http://www.racingjunk.com/category/1...AND-MORE-.html
hammertime is offline  
Old 06-30-2009, 11:04 AM
  #12  
onedragracer
Member
JUNIOR BUILDER
Thread Starter
 
Join Date: Aug 2007
Location: Odessa Texas
Posts: 81
Default

Not with this converter. I talked to James Monroe this morning and I went over everything I have checked and done. He said that I have covered all the basics. I'm gonna take out my 7al3 box tonight and put in a spare 7a box to see what happens.
onedragracer is offline  
Old 06-30-2009, 11:56 AM
  #13  
hammertime
Senior Member
RACING JUNKIE
 
Join Date: May 2003
Location: Coldwater, MI
Posts: 2,998
Default

He didnt think it was the pump did he ?
hammertime is offline  
Old 06-30-2009, 01:47 PM
  #14  
onedragracer
Member
JUNIOR BUILDER
Thread Starter
 
Join Date: Aug 2007
Location: Odessa Texas
Posts: 81
Default

James did suggest the pump could be flowing too much, but the MSD box change will tell if its fuel or spark related. The car never really ran what I thought it should run. Maybe I have a weak ignition problem but running VP113 it wouldn't show up. Now switching to alcohol with alot more fuel volume a weak ignition might not keep up. The engine doesn't bang or pop just really sluggish coming up on the converter. The best E.T. with a carburetor was 8.89 @149. Should be running 8.45 to 8.50 @ 155.
onedragracer is offline  
Old 07-28-2009, 10:25 AM
  #15  
onedragracer
Member
JUNIOR BUILDER
Thread Starter
 
Join Date: Aug 2007
Location: Odessa Texas
Posts: 81
Default

Follow up on my 1060 terminator system. After several weeks of checking everything possible with the fuel system, my problem turned out to be a converter that was too tight. I had the converter loosen up to 6150 and it works like a champ. Second weekend out I won the Electronics race at one of our local tracks. [email protected] in 5700 DA. Not too bad for a 468!
onedragracer is offline  
Old 07-28-2009, 08:27 PM
  #16  
hammertime
Senior Member
RACING JUNKIE
 
Join Date: May 2003
Location: Coldwater, MI
Posts: 2,998
Default

great job !
thanks for letting us know what it was, I been wondering

Hard to beat a good 468 for the money to build them, what weight car is yours ?
hammertime is offline  
Old 07-28-2009, 09:28 PM
  #17  
onedragracer
Member
JUNIOR BUILDER
Thread Starter
 
Join Date: Aug 2007
Location: Odessa Texas
Posts: 81
Default

I don't no what the weight is yet David, I haven't been on scales yet but I definately like the car now. First dragster, always had door cars, but I will never go back. I think it has alittle more in it with some more tuning. Ordered a EGT today to help. But for now I have a 85 pill in the barrel valve and 38 jets in the nozzles with 28% leakdown. Leaves hard and pulls like a SOB in high gear. 1.16 60ft.
onedragracer is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service