Rewiring the "BEAST"

Old 02-24-2013, 06:10 PM
  #11  
TheYellaBrick
Senior Member
RACING JUNKIE
 
TheYellaBrick's Avatar
 
Join Date: Mar 2008
Location: Emmett, Idaho
Posts: 7,334
Default


RAINBOW colored spaghetti !
TheYellaBrick is offline  
Old 02-24-2013, 06:25 PM
  #12  
TheRabbit
Senior Member
RACING JUNKIE
 
TheRabbit's Avatar
 
Join Date: Jan 2007
Location: Augusta, Ga.
Posts: 2,295
Default

From above for Beast.






TheRabbit is offline  
Old 02-25-2013, 06:14 AM
  #13  
Harbone
Moderator
RACING JUNKIE
 
Harbone's Avatar
 
Join Date: Aug 2007
Posts: 4,040
Default

Originally Posted by TheYellaBrick

RAINBOW colored spaghetti !

Exactly!!! :shock:
__________________
Chris

As close to "Normal" as I can get...
Harbone is offline  
Old 02-25-2013, 04:25 PM
  #14  
BEAST477
Senior Member
RACING JUNKIE
Thread Starter
 
BEAST477's Avatar
 
Join Date: Feb 2007
Location: Michigan
Posts: 1,908
Default

Thanks Rabbit. Things weren't really as bad as that first pic looks. I had just installed the air shifter and a new play back tach and did a quick hookup just to test as I knew I was going to redo this winter.
BEAST477 is offline  
Old 03-11-2013, 06:02 PM
  #15  
BEAST477
Senior Member
RACING JUNKIE
Thread Starter
 
BEAST477's Avatar
 
Join Date: Feb 2007
Location: Michigan
Posts: 1,908
Default

Well almost done with the wiring. Fired it up tonight everything works great. Oh what a refreshing smell and sound.. Got to clean up the inside put the seat back in and a few little things and I will post some more pics.
BEAST477 is offline  
Old 03-18-2013, 05:12 PM
  #16  
BEAST477
Senior Member
RACING JUNKIE
Thread Starter
 
BEAST477's Avatar
 
Join Date: Feb 2007
Location: Michigan
Posts: 1,908
Default

Here is the finished product.










Man am I glad this is done. All new wiring and repainted rollcage with Hammertone Gray. I might have to get Rabbit to fix this for me again. Oh how I hate photo bucket. :x
BEAST477 is offline  
Old 03-18-2013, 06:07 PM
  #17  
TheYellaBrick
Senior Member
RACING JUNKIE
 
TheYellaBrick's Avatar
 
Join Date: Mar 2008
Location: Emmett, Idaho
Posts: 7,334
Default

Purty Purty Purty !
TheYellaBrick is offline  
Old 03-22-2013, 01:30 PM
  #18  
BEAST477
Senior Member
RACING JUNKIE
Thread Starter
 
BEAST477's Avatar
 
Join Date: Feb 2007
Location: Michigan
Posts: 1,908
Default

Thanks DD. Thanks to you also Rabbit for helping me with the pics. I think I got it now. ops:
BEAST477 is offline  
Old 03-24-2013, 07:29 AM
  #19  
Harbone
Moderator
RACING JUNKIE
 
Harbone's Avatar
 
Join Date: Aug 2007
Posts: 4,040
Default

Great work!

Now you know all thats left to do?

STAND ON THE GO PEDAL!!

__________________
Chris

As close to "Normal" as I can get...
Harbone is offline  
Old 03-24-2013, 10:45 AM
  #20  
BEAST477
Senior Member
RACING JUNKIE
Thread Starter
 
BEAST477's Avatar
 
Join Date: Feb 2007
Location: Michigan
Posts: 1,908
Default

Originally Posted by Harbone
Great work!

Now you know all thats left to do?

STAND ON THE GO PEDAL!!

Thanks Chris. Just waiting for "Spring" to get here.
BEAST477 is offline  

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -