Help with whats wrong with engine.....

Old 08-22-2009, 07:27 PM
  #11  
MEMRACING62
Senior Member
RACING JUNKIE
 
Join Date: Sep 2007
Location: orland pk il
Posts: 2,429
Default

after hearing the second recording i would agree with mopar :wink:
MEMRACING62 is offline  
Old 08-22-2009, 07:48 PM
  #12  
FullTimeRacing
Senior Member
DYNO OPERATOR
 
Join Date: Mar 2008
Location: New Orleans,La
Posts: 515
Default

It's definitely a clunker.

tell him to pull the valve cover
FullTimeRacing is offline  
Old 08-22-2009, 07:51 PM
  #13  
kwkracing
Senior Member
RACING JUNKIE
 
Join Date: Dec 2004
Location: austin texas
Posts: 729
Default

Sounds like no oil pressure and the lifter collapsed and a torn rod bearing on that cylinder

First video sounds like a rod knock and broke piston
kwkracing is offline  
Old 08-22-2009, 07:55 PM
  #14  
DirkaDirka
Senior Member
RACING JUNKIE
Thread Starter
 
DirkaDirka's Avatar
 
Join Date: Jul 2009
Location: Clarksville, TN
Posts: 1,951
Default

OK update.....
he has oil pressure. Ok i will have him pull the valve cover. What should he look for under there.

Also what would you suggest be done.
DirkaDirka is offline  
Old 08-22-2009, 08:06 PM
  #15  
DirkaDirka
Senior Member
RACING JUNKIE
Thread Starter
 
DirkaDirka's Avatar
 
Join Date: Jul 2009
Location: Clarksville, TN
Posts: 1,951
Default

Originally Posted by MEMRACING62
well it will be put out of its misery. if it was a horse it would have to be shot :shock:
I agree. I would have put it down. Then gotten a new horse. LOL
DirkaDirka is offline  
Old 08-22-2009, 08:08 PM
  #16  
FullTimeRacing
Senior Member
DYNO OPERATOR
 
Join Date: Mar 2008
Location: New Orleans,La
Posts: 515
Default

run it with out the valve cover and video it.

this could get fun.
FullTimeRacing is offline  
Old 08-22-2009, 08:14 PM
  #17  
bjuice
Administrator
RACING JUNKIE
 
bjuice's Avatar
 
Join Date: Apr 2003
Location: Greenville s.c.
Posts: 3,239
Default

Hey i resemble that Remark..i did run them in the past with Open valve covers when adjusting Hydraulic lifters...then i got smart and cut the center out of old valve covers...lot less messy...

Stay away from the engine D....Too many out there to choose from
__________________
Bjuice..

"I'M YOUR HUCKLEBERRY ! "
bjuice is offline  
Old 08-22-2009, 08:16 PM
  #18  
kwkracing
Senior Member
RACING JUNKIE
 
Join Date: Dec 2004
Location: austin texas
Posts: 729
Default

OK update.....
he has oil pressure. Ok i will have him pull the valve cover. What should he look for under there.


The rocker arm laying off to the side!!! lol
kwkracing is offline  
Old 08-22-2009, 08:22 PM
  #19  
TheYellaBrick
Senior Member
RACING JUNKIE
 
TheYellaBrick's Avatar
 
Join Date: Mar 2008
Location: Emmett, Idaho
Posts: 7,334
Default

Originally Posted by mopar1968
sound's like either a camshaft lobe gone and hyd lifter is trying to compensate, or bottom out of lifter. But what the Hell do i know i am a ''Mopar man'' :!: :!: :!:


''JUST MY TWO CENT'S WORTH''
X3. Trade it in on the Kash 4 Klunker program before they(WE) run outa money ! WAIT WE have already run outa money !! :shock: :shock: :shock: In that case, put a brick on the gas pedal and watch the fun !! Sell tickets and pay for a new car !!
TheYellaBrick is offline  
Old 08-22-2009, 08:39 PM
  #20  
DirkaDirka
Senior Member
RACING JUNKIE
Thread Starter
 
DirkaDirka's Avatar
 
Join Date: Jul 2009
Location: Clarksville, TN
Posts: 1,951
Default

OK tomorrow he is going to video the engine running with the valve cover off. That way you can get an inside look at it.
DirkaDirka is offline  

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service