New Ride

Old 07-28-2009, 07:32 PM
  #11  
hammertime
Senior Member
RACING JUNKIE
Thread Starter
 
Join Date: May 2003
Location: Coldwater, MI
Posts: 2,998
Default

thanks for the replies guys

This one isnt as fast as the other *yet* bad track with bad tire shake I am sure wasnt helping went [email protected] [email protected] I am sure I'll have it back in the 4.7/7.5 zone very soon. I was taking it very easy first time out, launch light and shift very light.

I feel I did ok on both cars, was hard to get rid of the old one it was what we call old and trusty, been down the road of getting rid of a good car before but in order to not loose a lot of money on dragsters it seems ya have to move them every few years. I upgraded 4 years here, with some better parts, this one actually has the same powdercoating just without the silver chrome under it. I am thinking a wild paint job this winter will help this car. It does have nice parts though, dual brakes, beadlocks and nicer front rims. Plus its suppose to be about 80lbs lighter then the last car
hammertime is offline  
Old 07-29-2009, 05:25 PM
  #12  
kod99
Senior Member
MASTER BUILDER
 
Join Date: Sep 2008
Location: Red Deer, AB Canada
Posts: 213
Default

That's a sweet looking ride David. Now you have a reason to buy more shiny chrome parts this winter!
Give us some specs on it!
kod99 is offline  
Old 07-29-2009, 08:03 PM
  #13  
hammertime
Senior Member
RACING JUNKIE
Thread Starter
 
Join Date: May 2003
Location: Coldwater, MI
Posts: 2,998
Default

I may not bling this one out, actually thinking about going black with it

Specs of it
06 Danny Nelson Racecraft, 235" swingarm suspension (dual shock in front of rear), 24" cage, saldana radiator, 16x16 alum start beadlocks, dual strange brakes on rear ( I unhooked one set untill I get two pedals in the car), bolt through moser center section. Once I get everything sorted out it should be right back where my other car was, if not a bit faster
hammertime is offline  
Old 07-30-2009, 05:17 PM
  #14  
TS1955
Senior Member
DYNO OPERATOR
 
Join Date: Aug 2007
Location: Lost Creek, WV
Posts: 533
Default

Great looking ride Hammer! I like the front wheels!!!

TS1955
TS1955 is offline  
Old 07-30-2009, 07:56 PM
  #15  
kod99
Senior Member
MASTER BUILDER
 
Join Date: Sep 2008
Location: Red Deer, AB Canada
Posts: 213
Default

Originally Posted by hammertime
I may not bling this one out, actually thinking about going black with it

Specs of it
06 Danny Nelson Racecraft, 235" swingarm suspension (dual shock in front of rear), 24" cage, saldana radiator, 16x16 alum start beadlocks, dual strange brakes on rear ( I unhooked one set untill I get two pedals in the car), bolt through moser center section. Once I get everything sorted out it should be right back where my other car was, if not a bit faster
Sounds like great car David.

I was planning on putting dual rear brakes on mine this winter. Do I need two pedals? I was going to run two master cylinders with one pedal and perhaps mount two brake pressure guages on the dash.
kod99 is offline  
Old 08-16-2009, 04:52 AM
  #16  
hammertime
Senior Member
RACING JUNKIE
Thread Starter
 
Join Date: May 2003
Location: Coldwater, MI
Posts: 2,998
Default

2nd weekend out in car and it visits a final @ US 131 Motorsports Park

This car is every bit as good as my last one, had 4 packages less then 15 thousands in 7 rounds. 8)
hammertime is offline  
Old 08-16-2009, 04:22 PM
  #17  
BEAST477
Senior Member
RACING JUNKIE
 
BEAST477's Avatar
 
Join Date: Feb 2007
Location: Michigan
Posts: 1,908
Default

Good job David. Your car was running strong. Got mine figured out and back together today. What a relief.
BEAST477 is offline  
Old 08-16-2009, 05:07 PM
  #18  
bbchevy
Senior Member
RACING JUNKIE
 
Join Date: Mar 2003
Location: Fountain,MICHIGAN
Posts: 856
Default New car

Originally Posted by hammertime
2nd weekend out in car and it visits a final @ US 131 Motorsports Park

This car is every bit as good as my last one, had 4 packages less then 15 thousands in 7 rounds. 8)
Thats GREAT,NEWS!
Later
G 8)
bbchevy is offline  
Old 08-16-2009, 05:50 PM
  #19  
hammertime
Senior Member
RACING JUNKIE
Thread Starter
 
Join Date: May 2003
Location: Coldwater, MI
Posts: 2,998
Default

Originally Posted by BEAST477
Good job David. Your car was running strong. Got mine figured out and back together today. What a relief.
Mike was it what ya thought it was ?


thanks Greg It was a good feeling, last car was flat out awesome and this one seems to be just as good. I had a hired gun in there today at Osceola Dragway, ran within 8 thousands between 2 TT and 1st rd .. he went red first round and dead on with a 6. Not bad for a 6 hr period in 95 degree track that usually is miserable.
hammertime is offline  
Old 08-17-2009, 03:14 PM
  #20  
BEAST477
Senior Member
RACING JUNKIE
 
BEAST477's Avatar
 
Join Date: Feb 2007
Location: Michigan
Posts: 1,908
Default

Yeah David it was just what we talked about. All is good now I think. Wont know till Saturday.
BEAST477 is offline  

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -