Big Shot 400 - How to activate

Old 05-07-2009, 08:04 PM
  #11  
chevyfireball
Senior Member
MASTER BUILDER
 
Join Date: Dec 2005
Location: Napier, New Zealand
Posts: 230
Default

Originally Posted by dparker
Originally Posted by chevyfireball
You shouldn't activate the nos unless you have wide open throttle or it could get ugly. And they say no more than 20 seconds. Go to the Holley website and you can download instructions for the Big Shot kit. Make sure your engine is built to handle nitrous and don't go giving it a shitload right away. Start small and increase the jetting gradually.
20 seconds, how long is your track? lol.
LOL. I thought he might be using it on the street.
chevyfireball is offline  
Old 05-07-2009, 09:19 PM
  #12  
TheYellaBrick
Senior Member
RACING JUNKIE
 
TheYellaBrick's Avatar
 
Join Date: Mar 2008
Location: Emmett, Idaho
Posts: 7,334
Default

20 Fast and Furious movie seconds.........................................
.................................................. ...............................................120
second quarter mile :roll: :roll: :roll: :roll:
TheYellaBrick is offline  
Old 05-08-2009, 06:43 AM
  #13  
dparker
Senior Member
RACING JUNKIE
 
Join Date: Jun 2003
Location: Hobbs, NM
Posts: 842
Default

Seriously jreiley don't run your 400hp nos more than 10 seconds where ever your at. I would recommend around 5 to 6 seconds right after you launch, sure will save alot of parts.
dparker is offline  
Old 05-19-2009, 03:02 PM
  #14  
onedragracer
Member
JUNIOR BUILDER
 
Join Date: Aug 2007
Location: Odessa Texas
Posts: 81
Default

Originally Posted by dparker
Seriously jreiley don't run your 400hp nos more than 10 seconds where ever your at. I would recommend around 5 to 6 seconds right after you launch, sure will save alot of parts.
Make sure the arming switch is mounted on the dash, You don't want to accidentally arm it by mistake during a time trial like someone I know.
onedragracer is offline  
Old 05-21-2009, 12:36 PM
  #15  
dparker
Senior Member
RACING JUNKIE
 
Join Date: Jun 2003
Location: Hobbs, NM
Posts: 842
Default

Originally Posted by onedragracer
Originally Posted by dparker
Seriously jreiley don't run your 400hp nos more than 10 seconds where ever your at. I would recommend around 5 to 6 seconds right after you launch, sure will save alot of parts.
Make sure the arming switch is mounted on the dash, You don't want to accidentally arm it by mistake during a time trial like someone I know.
That was eliminations and after the front end came down from a 4ft wheely. I still caught the guy and won the round. That was against the Barbarian in that Aglia. Man that was crazy, the front end came down and I hit the gas at the 60' and it yanked the wheels again and off we went. Everybody has to have something dumb they did at the track to be remembered by.lol.
dparker is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -