The 511 died Today

Old 04-30-2008, 01:49 PM
  #11  
topfool
Junior Member
APPRENTICE
 
Join Date: Jan 2005
Location: United Kingdom
Posts: 24
Default

R.I.P. the 511's..

mine died too ...

mind you it ran 8.00 @165 (5.00--1/8th) before I found a crack in it, well another crack that I didnt wqant to ignore..

I wanted a 7 but will take the 8.00...
topfool is offline  
Old 04-30-2008, 02:02 PM
  #12  
lotsof454sss
Senior Member
DYNO OPERATOR
 
Join Date: Apr 2006
Location: North Georgia "GODS COUNTRY"
Posts: 539
Default

Well juice looks like you got to bite the bullet but look back at all the good times the 511 supplied you and look ahead at all your going to gain and really not all that much $$ to go bigger and better as you always do..HAHA..Sorry to hear it though but good luck and keep us posted on the happenings..I am still just sitting still here..Buying a few parts along for the future...
lotsof454sss is offline  
Old 04-30-2008, 05:51 PM
  #13  
bjuice
Administrator
RACING JUNKIE
Thread Starter
 
bjuice's Avatar
 
Join Date: Apr 2003
Location: Greenville s.c.
Posts: 3,239
Default

Perry your right...was a strong motor..for a little big block..i am gonna look closley at the collateral damage when i get everthing tore down..if nothing too serious anyhwere else i will put it back together..for a spare or put it in the wifes 69 camaro...teee heeeee......


Sam that was some aweful good ET'S to run outta that little motor..i did not realize you had a 511 ??


we will gfet the game plan together as we go...i am working a little at a time to get the motor out...getting back to the vette..i am close to my 1st shake down in the vette...going over all the nuts and bolts one more time...gettting ansy...here are a few pics of both cars this weekend ( Saturday)..i broke the camaro the next day... :cry:

played with the vette in the drive way...sucked my peanuts up on the ole bung-um hole....she is gonna pull........just getting use to where everything is for obvious reasons...lol



[img][/img]


[img][/img]

[img][/img]
__________________
Bjuice..

"I'M YOUR HUCKLEBERRY ! "
bjuice is offline  
Old 04-30-2008, 10:37 PM
  #14  
topfool
Junior Member
APPRENTICE
 
Join Date: Jan 2005
Location: United Kingdom
Posts: 24
Default

Brian, The car had a 511 in when I bought it, I changed the heads when I dropped a valve (big over rev) but basically its the same engine god know how many runs it had on it... but I've not even put rings or bearings in it....

I'll try and find another block sometime to build it as a spare.. but as soon as I get my new shop built I'll start building the 540, KB olds block, callies crank, oliver billet rods, 15:1 je and my brodix -3Xtra oval ports... I'll start it on the carb and gas but probably go injected alky sometime... I do have a box of 11.5 :1 coated pistons thatwould be nice to use up if I had a blower, mind you injected nitro sounds good too...

Be lucky with that vette...
topfool is offline  
Old 05-03-2008, 05:29 PM
  #15  
qtrmile2
Senior Member
DYNO OPERATOR
 
Join Date: May 2003
Location: Moscow Mills, Mo.
Posts: 533
Default

Hey Brian,
Sorry to hear about the motor in the Camaro. Your safe and that's all that matters.
Good luck with the Vette this summer. Can't wait to hear some ET numbers. Do you know when your gunna make some shake down runs?
qtrmile2 is offline  
Old 05-03-2008, 07:46 PM
  #16  
bjuice
Administrator
RACING JUNKIE
Thread Starter
 
bjuice's Avatar
 
Join Date: Apr 2003
Location: Greenville s.c.
Posts: 3,239
Default

Originally Posted by qtrmile2
Hey Brian,
Sorry to hear about the motor in the Camaro. Your safe and that's all that matters.
Good luck with the Vette this summer. Can't wait to hear some ET numbers. Do you know when your gunna make some shake down runs?
renting one our our local tracks Thursday after next..we have about 5 hours for solo passes before the track opens for thursday night test and tune..

the vette has a real tight NOS converter..should NOT 60FT like it would with a little NOS lossening up the converter or a all motor..i expect to leave 3 or more tenths on the table with the current converter..my chassis guy has already told me that the wheel speed with the tight converter on the big end may cause the car to move around a bit more than a loser converter resulting in a little more driving of the car however i am leaving the converter alone i expect to it hit with a 200/250 shot once i get the feel for the car...

below is a pic i took of it tonight after adjusting wheelie bars....


also i pic of the 511 lifter valley whowing the broke wheel off lifter...ouchhhh :shock:








[img][/img]


[/img]
__________________
Bjuice..

"I'M YOUR HUCKLEBERRY ! "
bjuice is offline  
Old 05-03-2008, 08:43 PM
  #17  
Oldewalnut
Senior Member
SENIOR BUILDER
 
Join Date: Feb 2008
Location: Nineveh, Indiana
Posts: 108
Default

Hey juice, I'll second that ouch!!!

I lunched a 289 Ford, D/MP motor in the late 70's. Rod twisted, piston siezed and took out a piece of the bore and the lifter valley. Amazing part was, the front 2-3 lobes of the cam and the timing chain were intact, drove the car back to the pits. Wasn't much left to salvage from that motor.
Oldewalnut is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service