Barry Grant EGT

Old 01-22-2008, 11:13 AM
  #11  
BEAST477
Senior Member
RACING JUNKIE
Thread Starter
 
BEAST477's Avatar
 
Join Date: Feb 2007
Location: Michigan
Posts: 1,908
Default

Plugs have looked pretty good, tan to light brown. I run 39 degrees. My car is a '65 Nova, burgandy in color with a dragon mural down the side, says THE BEAST on the scoop. If you've seen it you would remember it I'm sure.
BEAST477 is offline  
Old 01-22-2008, 02:22 PM
  #12  
hammertime
Senior Member
RACING JUNKIE
 
Join Date: May 2003
Location: Coldwater, MI
Posts: 2,998
Default

Originally Posted by BEAST477
Plugs have looked pretty good, tan to light brown. I run 39 degrees. My car is a '65 Nova, burgandy in color with a dragon mural down the side, says THE BEAST on the scoop. If you've seen it you would remember it I'm sure.
Does it run correct ? Sounds like a possible EGT reading is incorrect. I think i have seen the car is the dragon green ? I've had a few different cars up there in the last few years, mostly a yellow dragster with blue/green/orange on the side of it.
hammertime is offline  
Old 01-23-2008, 03:47 PM
  #13  
BEAST477
Senior Member
RACING JUNKIE
Thread Starter
 
BEAST477's Avatar
 
Join Date: Feb 2007
Location: Michigan
Posts: 1,908
Default

Yeah, the car seems to run fine. Yes the dragon is green its breathing fire where the headers dump out thru the front fender. I'll have to keep a lookout for your car. Thanks for all the responses and all the help. Thanks Mike.
BEAST477 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -