Using a motor that has been sitting 8 years

Old 05-04-2014, 08:39 AM
  #1  
Swiley383
Senior Member
RACING JUNKIE
 
Swiley383's Avatar
 
Join Date: Apr 2010
Location: White Bluff TN
Posts: 625
Default Using a motor that has been sitting 8 years

Since I blew my 383 sbc i am thinking about putting my old motor back in it been sitting for over 8 years. Do you thing this motor would be ok? The oil psi was good when I pulled it but it has not been turned in several years. If it's not stuck should I do anything other than the basic tune up and prime the oil pump? The motor is a mild 454 I will probably change the valve spring as well.
Swiley383 is offline  
Old 05-04-2014, 08:05 PM
  #2  
TheYellaBrick
Senior Member
RACING JUNKIE
 
TheYellaBrick's Avatar
 
Join Date: Mar 2008
Location: Emmett, Idaho
Posts: 7,334
Default

What environment has it been in all this time ? Pull the plugs and see if there is any corrosion build up from moisture inside the heads/block. If so, count on the cyls being crusty ! Beg,borrow, or steal a bore scope and take a looksee into each hole. Drain the oil and see if and condensation comes out.
TheYellaBrick is offline  
Old 05-05-2014, 10:07 AM
  #3  
Swiley383
Senior Member
RACING JUNKIE
 
Swiley383's Avatar
 
Join Date: Apr 2010
Location: White Bluff TN
Posts: 625
Default

I did not think about the bore scope I will try to locate one.
Thanks
Swiley383 is offline  
Old 05-05-2014, 05:02 PM
  #4  
TheRabbit
Senior Member
RACING JUNKIE
 
TheRabbit's Avatar
 
Join Date: Jan 2007
Location: Augusta, Ga.
Posts: 2,295
Default

Friend of mine bought a Ford Super Cobra Jet motor that had been sitting outside for about 20 years. Somebody stole the carb off it a long time ago and a tarp was put over the motor.
It fired up and ran fine.
No way is my luck that good, but you may be ok.
TheRabbit is offline  
Old 05-14-2014, 05:09 AM
  #5  
chevynovaman
Senior Member
SENIOR BUILDER
 
chevynovaman's Avatar
 
Join Date: Sep 2008
Location: CENTRAL WISCONSIN
Posts: 114
Default

The motor I have in my mud dragster sat 15 years, and run good when put back in. If
it was mine I would probly change valve springs from sitting.
chevynovaman is offline  
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service