Brakes on my gbody

Old 01-03-2018, 03:44 PM
  #1  
bad1980malibu
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Aug 2009
Posts: 3
Default Brakes on my gbody

I change my Malibu to manual brake bought the kit from trz. I have nine inch rear with disc brakes. Is there anything else I have to do to make it work. Thanks
bad1980malibu is offline  
Old 01-03-2018, 03:52 PM
  #2  
Harbone
Moderator
RACING JUNKIE
 
Harbone's Avatar
 
Join Date: Aug 2007
Posts: 4,036
Default

What all is included in the kit?
__________________
Chris

As close to "Normal" as I can get...
Harbone is offline  
Old 01-03-2018, 04:02 PM
  #3  
bad1980malibu
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Aug 2009
Posts: 3
Default

The master cylinder and plate for fire wall and the linkage rod for the brake petal. The rear is a spraker racing nine inch with gm calibers the brake petal feels good. But when I drive it it don’t stop like I want
bad1980malibu is offline  
Old 01-03-2018, 05:12 PM
  #4  
Harbone
Moderator
RACING JUNKIE
 
Harbone's Avatar
 
Join Date: Aug 2007
Posts: 4,036
Default

Are you still using a stock proportion valve?
__________________
Chris

As close to "Normal" as I can get...
Harbone is offline  
Old 01-04-2018, 03:15 PM
  #5  
Swiley383
Senior Member
RACING JUNKIE
 
Swiley383's Avatar
 
Join Date: Apr 2010
Location: White Bluff TN
Posts: 628
Default

Also check your lines. The rubber lines going from the steel line to the calipers can collapse inside.
Swiley383 is offline  
Old 01-04-2018, 03:54 PM
  #6  
bad1980malibu
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Aug 2009
Posts: 3
Default

I put new rubber line on front. I am still running the stock proportion valve.
bad1980malibu is offline  
Old 01-04-2018, 05:44 PM
  #7  
Harbone
Moderator
RACING JUNKIE
 
Harbone's Avatar
 
Join Date: Aug 2007
Posts: 4,036
Default

Get a adjustable proportion valve, the stock valve is not set up properly for a front and rear disc manual brake setup. its probably not sending enough pressure to the rear calipers.
have you done any hard braking to see what wheels lock up first?
__________________
Chris

As close to "Normal" as I can get...
Harbone is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information