help!!!!!!!

Old 06-09-2008, 07:08 PM
  #21  
us7race
Senior Member
EXPERT BUILDER
 
Join Date: Aug 2005
Location: Tell City, IN
Posts: 356
Default

Originally Posted by john858
not to highjack this thread but WHAT have you done to that truck to make it leave like that,these guys around here can't even come close to you with their s-10's.
Good Track Prep! 422ci and leaving the line at 4800. It has Ladder Bars with coil overs. Moroso Trick Springs..PM me and I'll give you a more detailed rundown if you want it..Thanks By the way. :wink:
us7race is offline  
Old 06-24-2008, 08:40 AM
  #22  
upstand
Junior Member
APPRENTICE
 
Join Date: May 2003
Posts: 14
Default

That looks exactly like my 400! I spit my driveshaft out at the finish line , it had a slight vibration for .5 seconds bere leaving!. However I think the trans may have been cracked before. I had a leak and I could never find it , the general area was where the cooling lines go in. I also cracked a Th350 before I switched to a 400. I too run poly engine and trans mounts and I'd say my body mounts are in poor condition. 70 Monte , 3850lbs w driver , 530 hp 383 , 4000 flash. If it makes you feel better I'm on my third trans. TH350 broke case , TH350 broke sprag , TH400 broke case.
upstand is offline  
Old 07-01-2008, 03:01 PM
  #23  
hardcore93s10
Junior Member
SHOW GUEST
 
Join Date: Dec 2007
Posts: 2
Default BROKEN BELLHOUSING

This definantly a drive shaft. Check for end play in shaft should have at least 3/4" of movement. I speak from my own experiance. it took me three transmission in less than 100' of use to figure out. When checking
Driveshaft make sure weight of car is on axles. If you have real soft springs remove the rear springs and check.
hardcore93s10 is offline  
Old 07-03-2008, 06:11 AM
  #24  
outlaw256
Senior Member
RACING JUNKIE
 
Join Date: Mar 2008
Location: falkville al
Posts: 1,766
Default

it aint the poly mounts, they do have movement, so you aint rigid there. if you have 12 pt. cage ,you have frame connecters, so you are solid there. body could fly off and i dont think it would cause that. i think it would have to have had a violent reaction to end up there.pinion angle , drive shaft or u joints are about all i can come up with. i could have been stressed when it was in the other car and broke on lucky you.good luck hope you find it fast before the cha-ching machine gets turned on high.
outlaw256 is offline  
Old 07-07-2008, 03:37 AM
  #25  
Tod74
Senior Member
RACING JUNKIE
 
Join Date: Sep 2007
Posts: 4,143
Default

Is the cage work recent? What I mean is...maybe the car is tweaked or something from the welding the cage in??? Got the trans twisted or in a bind and then when you put it to it it busts? IDUNO
Tod74 is offline  
Old 07-07-2008, 03:39 AM
  #26  
Tod74
Senior Member
RACING JUNKIE
 
Join Date: Sep 2007
Posts: 4,143
Default

Originally Posted by john858
not to highjack this thread but WHAT have you done to that truck to make it leave like that,these guys around here can't even come close to you with their s-10's.
I think he has the engine in the bed or something...lol


jk
Tod74 is offline  
Old 07-08-2008, 04:09 AM
  #27  
us7race
Senior Member
EXPERT BUILDER
 
Join Date: Aug 2005
Location: Tell City, IN
Posts: 356
Default

Originally Posted by Tod74
Originally Posted by john858
not to highjack this thread but WHAT have you done to that truck to make it leave like that,these guys around here can't even come close to you with their s-10's.
I think he has the engine in the bed or something...lol


jk
lol.. That is called a Hookin' track!! Since that picture, it just seems to spin. :evil: :x :?
us7race is offline  
Old 07-08-2008, 05:09 AM
  #28  
lively
Senior Member
RACING JUNKIE
 
lively's Avatar
 
Join Date: Nov 2004
Location: ILLINOIS
Posts: 2,191
Default

10 JOHN DEERE TRACTOR WEIGHTS!!!!! :lol: :lol: :lol: RIGHT IN FRONT OF THE REAR BUMPER!!!!!

LIVELY
lively is offline  
Old 07-08-2008, 06:16 AM
  #29  
Tod74
Senior Member
RACING JUNKIE
 
Join Date: Sep 2007
Posts: 4,143
Default

Lively you just gave me an idea.
I have about 600 lbs worth of Olympic free weights( you know barbell and plates) I could pile them in the trunk for a pass just so I could get a picture like his...lol :P

My car 60 fts about the same as his (1.32) but it sure don't do that.

Don't really think I want it to either...I tear up enough parts as it is. :lol:
Tod74 is offline  
Old 07-08-2008, 06:38 AM
  #30  
altereddoug
Member
JOURNEYMAN
 
Join Date: Jan 2004
Location: illinois
Posts: 31
Default

We had a tranny rebuilt about ten years ago and they didn't put the bushing in the front pump for use with a turbo spline input shaft. It lasted
3/4 of a run.
Also we used to run a mounts like what you are using, now we just run stock mounts with longer bolts in them so they bottom out and get about a 1/4" travel. Even though it should never move and if it would come apart the bolts keep the case from coming out.

5.60's 1/8 in a 4 link car and haven't broke a tranny case in a very long time.
altereddoug is offline  

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service