Results 1 to 5 of 5

Thread: Help identifying what is inside this powerglide

  1. #1

    Help identifying what is inside this powerglide

    Hi everyone,

    I was hoping someone could identify what is going on in my powerglide. I went to change out the transmission gasket and filter, and found what appears to be a solenoid inside the pan attached to the valve body (see "A" in the picture).

    The unusual thing about it is that I already have a seperate solenoid outside of the pan that activates the transbrake and is wired to the shifter button (see "B" in the picture).

    The part in the pan that looks like a solenoid has two lead wires off of it. One is attached to ground, and the other leaves the transmission through a hole in the case but that wire has been cut. So I imagine that solenoid is not doing anything?

    Can anyone make sense of this.

    Thanks.

    10.jpg

  2. #2
    Senior Member RACING JUNKIE mytmouz's Avatar
    Join Date
    May 2006
    Location
    Pelahatchie, MS
    Posts
    983
    I am going to say this trans has been assembled out of a couple of different ones at some point in time. The solenoid in the pan most likely did what the one in the case now does. Probably the only thing the unused one is doing now is keeping the piston in place...
    If you think nobody cares, try missing a payment...

  3. #3
    Thanks for that explanation. It certainly makes sense with the car's history.

    So in reassembling everything, I should just leave the "unused" solenoid in the pan to hold in the piston it used to move or should I be thinking of a way to remove it and cap the hole? If I leave it in, do you think I need to worry about servicing the unused piston or solenoid (or any of its gaskets) in the future, or is it fine to just remain there without attention? I'm including a close up of the extra solenoid.

    Thanks again for your guidance.

    11.jpg
    Last edited by hawkmoon77; 09-05-2014 at 09:23 AM.

  4. #4
    Senior Member RACING JUNKIE mytmouz's Avatar
    Join Date
    May 2006
    Location
    Pelahatchie, MS
    Posts
    983
    I couldn't say just by looking at a pic. It has some type of mods for it to work, ( I am assuming it was working and you were just fixing a leak when you found it). I would run it until it fails, then worry about it if it were me...
    If you think nobody cares, try missing a payment...

  5. #5


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy