Results 1 to 3 of 3

Thread: Building a tuneable O2 sensor????????

  1. #1
    Member MASTER JOURNEYMAN
    Join Date
    Aug 2007
    Posts
    45

    Building a tuneable O2 sensor????????

    My son has a 1988 K5 Blazer with a TBI 350 that is bone stock with the exception that it has an after market duel exhaust system installed with duel cats, crossover pipe, stainless steel mufflers, and all plumbed with alluminized pipe, a very nice system. Like almost everyone that has ventured down this road the Check Engine light comes on ever so often and checking the codes gives a bad O2 sensor which is pretty common with these exhaust conversions from what I understand. It just got a new O2 sensor just to be on the safe side and nothing changed. I have noticed that the harder this engine is run the less the light comes on and it seems to like the heat of the summer better than the cool of the winter because it comes on far less in the summer. I have talked to some one that can write us a custom chip for this situation and they say this would probably fix the problem, but no guarantees. I was driving home from work the other day and grilling myself about how there might be an alternative cure for this problem and that is when it hit me: What if you put a potentiometer in line with this O2 sensor and made it adjustable? Sounds kind of far fetched but the more I thought about the more I think it just might work. I guess the biggest issue would be to know if the O2 sensor gains or looses resistance as it heats up and if so how much and at what point will it flag an alarm and set the check engine light off? Any help from you tech guys would be greatly appreciated........

  2. #2
    Senior Member DYNO OPERATOR
    Join Date
    Aug 2007
    Location
    Lost Creek, WV
    Posts
    533
    An O2 is a tuning tool. You should adjust the vehicle to the O2. Not the O2 to the vehicle. If the light keeps coming on then your air to fuel ratio needs corrected. JMO.

    TS1955

  3. #3
    Senior Member EXPERT BUILDER gearhead1011's Avatar
    Join Date
    Jan 2004
    Location
    Shepherdsville, KY
    Posts
    313
    It really depends on the code that it's setting as to how to correct it. If it's a lean or rich fuel control code then there is probably something wrong with the fuel control. If it's a slow response problem then it could be related to the exhaust mods. IIRC that thing has a singe sensor with one wire which means it is a non-heated O2. If the exhaust mods are what's causing the problem and the sensor is cooling off at low loads/engine speed then you might try wiring in a heated O2.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy