Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: 1055 rons terminator problems HELP please

  1. #1

    1055 rons terminator problems HELP please

    i have a 408 sbc with the 1055 just put it on over the winter and not right since. hard to start. missing half track. and even if i get it to stop missing still hard to start. started out with a 1/2 pump and even tried a 0 pump still nothing rons told me to start out with 90 return and 33 jets . but i have been up and down on both and still cant figure it out. the exhaust temp will not give me a good ready for some reason it is reading like 1500 degrees which is not right even took the terminator off and put a alch carb on it and still 1500 degrees i have tried almost everything please any infomation[/b]

  2. #2
    Senior Member DYNO OPERATOR
    Join Date
    Jan 2004
    Location
    central Illinois
    Posts
    459

    1055

    Have you tried to talk to James Monroe at killerrons.com?

  3. #3
    Senior Member RACING JUNKIE
    Join Date
    May 2003
    Location
    Coldwater, MI
    Posts
    2,998

    Re: 1055 rons terminator problems HELP please

    Quote Originally Posted by smiley2947
    i have a 408 sbc with the 1055 just put it on over the winter and not right since. hard to start. missing half track. and even if i get it to stop missing still hard to start. started out with a 1/2 pump and even tried a 0 pump still nothing rons told me to start out with 90 return and 33 jets . but i have been up and down on both and still cant figure it out. the exhaust temp will not give me a good ready for some reason it is reading like 1500 degrees which is not right even took the terminator off and put a alch carb on it and still 1500 degrees i have tried almost everything please any infomation[/b]
    Is it going WOT fuel on the fuel spool when you push in the fuel shutoff ? Does it still have the start-aid in it ? Whats tha barrel valve leak down and blade gap ? They are simple to tune.
    David Lanning
    IHRA NHRA 387B

    Fleenor Racing Transmission
    419-280-1406
    Lanning Electric
    Complete Drag Car Wiring
    APD Race Engines
    www.apdracing.com

  4. #4
    Senior Member RACING JUNKIE
    Join Date
    Jan 2006
    Location
    La.
    Posts
    2,890
    A good starting point is to set the throttle blades at .002, set the leak down between 24%and 28%. With a 0-1/2 pump it should run with .085/.105 pill.
    I suspect the barrel valve is set to way too much leakdown and at WOT you're going over center with that high of exhaust temp. It should run 1250/1350 at WOT under load.
    One thing you didn't say are you running gas or alcohol? If you're running gas set the leakdown at 1/2 of what you would set it with alcohol.
    I run both rons stuff and Hilborn, but all on alcohol. But i built a B/BLk that going to run gas with a hilborn stacks injection. It has been so long since i've ran gas i had to call Hilborn to find out what to set the leakdown to.
    On the starting problem, turn off the swith and close the fuel shutoff at the same time that way the fuel doesn't drain back down from the injection. on my toilet bowl car it starts like a carb, but it is a little hard to start after it sets a week, but by the time the oil pressure comes up it's ready to start. I normally crank it with the swith off until oil pressure is up then flip the swith.
    JMO

    Zip.

  5. #5
    i am running alcohol . the leakdown is 28% and i even changed the barrel valve maybe thinking it was bad. i do have a starting aid on it. but even after the car is warmed up its hard to start. and yes i have talked to james at killer rons. he said to start at 90 return pill and 33 jets but no luck

  6. #6
    i would even pay someone to come tune it or fix it if there is anyone around this area

  7. #7
    Senior Member RACING JUNKIE
    Join Date
    Mar 2003
    Location
    Fountain,MICHIGAN
    Posts
    856

    Rons?

    Quote Originally Posted by smiley2947
    i would even pay someone to come tune it or fix it if there is anyone around this area
    Well That DEPENDS,.........??
    Where are you Located?
    I would start with BASIC plumbing,and go from there,........
    I have NEVER had a System that I could NOT Fix!

    Later
    G 8)
    Green BULBS and WIN Lights!!!

  8. #8
    where i race is in radford, virginia

  9. #9
    Senior Member RACING JUNKIE
    Join Date
    Jan 2006
    Location
    La.
    Posts
    2,890

    Re: Rons?

    Quote Originally Posted by bbchevy
    Quote Originally Posted by smiley2947
    i would even pay someone to come tune it or fix it if there is anyone around this area
    Well That DEPENDS,.........??
    Where are you Located?
    I would start with BASIC plumbing,and go from there,........
    I have NEVER had a System that I could NOT Fix!

    Later
    G 8)
    X2, most of them are as easy to tune as falling off a log. Couple of things to look at, is the pump mounted low?(not higher than the tank) Have you syncronized the butterflys so that all close tight? Are the throttle shafts tight in the bores? Are yu running atleast a #8 line to the pump? and what size fuel filter are you running, it could be starving for fuel on top end.

    Just a few guesses.

    Zip.

  10. #10
    everything just came back from rons everything checked out okay. i have 12 line i have a filter on it but i took it off cuz i thought it was straving at top end yes they are suppose to be easy to tune i have a guy that has this setup on his rail and he cant figure it out either


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy