Results 1 to 9 of 9

Thread: Why can't I see the GAS

  1. #1

    Why can't I see the GAS

    I recently put a completely stock 454 into my 4x4. I got it runnin real good and today I jus got it back from the muffler shop and took it for spin. When I was driving it and I got kinda heavy on the throttle it shifted into 2nd and stumbled for a lil bit then came alive. I didnt think much about it at the time til I stopped it did it again. So I got home and popped the hood to see if maybe I had gotten sum water in my gas and thats when i noticed i had almost no gas in my clear in line filter. It would jus shoot a lil in every once in a while even if I rev'd the engine. I installed a new holley manual fuel pump when I installed the engine so I dont think this is the problem. does anyone have any suggestions?

  2. #2
    Senior Member RACING JUNKIE
    Join Date
    Sep 2007
    Location
    Montvale, VA
    Posts
    1,431
    I cannot explain it,but those clear filters can be misleading sometimes. I know it seems like they should run absolutely full of fuel,but I have never seen one do it. I know it sounds impossible,but that is just my experience. Can you tell if the stumble was a lean-surge or a rich-bog? Also,ignition issues can closely mimic fuel delivery issues. It can be hard to tell the difference at times. A vacuum leak could be the culprit, as well
    "The problem with quotes on the Internet is that you cannot confirm their validity"- Abraham Lincoln

  3. #3
    Well I had an old distributer cap and rotor that was burned and old so I installed a new one 3 days ago. When engine is idling it is real smooth like a sewing machine. I couldn't really tell if it was a rich or lean bog but when I opened up the secondaries it sputtered for a second and then took off.

  4. #4
    Senior Member RACING JUNKIE
    Join Date
    Jan 2012
    Posts
    628
    Coupla things . . first, take that Goddamned clear fuel filter off and pitch it . . All I've ever seen them to be good for was coming apart and setting the engine afire . .

    Second . . put a fuel pressure guage on the line between the pump and the Carb and see if you have fuel pressure . . Eliminate the guess work. Chances are, you may have too much of a good thing . . or maybe not. At this point neither of us know . .

    Any guessing beyond this point would be a waste of broadband . .

  5. #5
    Senior Member RACING JUNKIE TheYellaBrick's Avatar
    Join Date
    Mar 2008
    Location
    Emmett, Idaho
    Posts
    7,334
    X2 on the filter, chuck it. WITH THE ENGINE OFF, pop the air cleaner, get a flashlight, NOT a lighter, look down the carb throat and work the throttle linkage to see if you have a good stream of fuel during that stroke. If it's a weak stream (us old fogies know all about weak streams :? :wink: ) then it's an accel pump circuit issue. Don't do this more than a couple of times or you'll flood heck out of the engine.
    What kinda carb ?

  6. #6
    Senior Member RACING JUNKIE
    Join Date
    Nov 2008
    Location
    Niagara Falls, NY
    Posts
    965
    Quote Originally Posted by DrivingMissDD
    NOT a lighter
    a friend of mine pull into a trailer park to pick up his girl... bottomed the car out on the speed bump on his way in and the car stalled out and wouldnt start. so he gets out of the car to look under neath it.... well apparently he pushed the exhaust pipe though the tank and was leaking gas..... the dummy used his BIC lighter to find this out cause he had no flashlight and well... the rest is self explanatory...... lol
    GOOD PARTS AREN'T CHEAP AND CHEAP PARTS ARE NEVER GOOD.........
    http://img.photobucket.com/albums/v2...lastscan-3.jpg

  7. #7
    Senior Member RACING JUNKIE fla1976's Avatar
    Join Date
    Aug 2007
    Posts
    1,530
    Sounds like it could be a clogged sock filter in the tank.

  8. #8
    Senior Member RACING JUNKIE lively's Avatar
    Join Date
    Nov 2004
    Location
    ILLINOIS
    Posts
    2,191
    what did the MUFFLER SHOP INSTALL???? IF WAS OK BEFORE THEN SOMETHING MIGHT HAVE GOT PINCHED/CUT/ OR UNHOOKED!!

    CHECK UNDERNEATH GOOD--DOES IT HAVE A SENSOR ON THE EXHAUST--IS IT OK OR LEAKING ??

  9. #9
    The carb is a Edelbrock this being a non performance application i figured it would be sufficient. The guys at the muffler shop installed 2 3inch pipes and Flowmasters from the headers to the back of the tires and no sensors on it. I'll check the fuel dump into the carband get back with yall. I really cant say it was runnin great before cause I dont hav hardly any run time on the engine it was open header so I didnt drive it much at all.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy