Results 1 to 1 of 1

Thread: 2 brl carb ? Fuel prob?

  1. #1
    Junior Member APPRENTICE
    Join Date
    May 2011
    Posts
    19

    2 brl carb ? Fuel prob?

    I have a 76 f/bird w/2brl 350 eng., I need to get by w/this setup until I get all the rest of the work done on this car and then poss change to 4brl set up but in the meantime I have a problem w/start and idle after setting for approx 30 to 60 min. It starts hard and idles irratic . Once going down the road it runs as if it is getting an uneven flow of gas, Not missing ,but runs uneven like it gets gas and then slows then runs and slows at even speeds . If I push on the gas it runs good but at even speed it runs and lets up then runs and lets up just at short intervals and it will even out and run fine after awhile . I have replaced plugs ,wires,cap/rotor.gas filter,3 of the 4 gas lines expt the one from the cannister to tank,incl. tank and sending/unit. I have run some carb cleaner through it also. Carb itself is all I can think of next ??? Anyone w/similar problems and remedies??

  2. Racing Junk


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy