Results 1 to 3 of 3

Thread: th 350 tranny?/ engine seems to bog down?

  1. #1
    Senior Member DYNO OPERATOR
    Join Date
    Mar 2009
    Location
    Booneville,Ms
    Posts
    505

    th 350 tranny?/ engine seems to bog down?

    I just put a th350 tranny in my truck and when its in reverse it does good but when you put it in drive the motor seems to lose all power and it won't hardly go down the road. Anybody know what I seem to have done wrong?

  2. #2
    Senior Member RACING JUNKIE
    Join Date
    Nov 2008
    Location
    Niagara Falls, NY
    Posts
    965
    sounds kinda like the converter is locked up. did you try and shift it manually....... does it still do it?
    GOOD PARTS AREN'T CHEAP AND CHEAP PARTS ARE NEVER GOOD.........
    http://img.photobucket.com/albums/v2...lastscan-3.jpg

  3. #3
    Senior Member DYNO OPERATOR
    Join Date
    Mar 2009
    Location
    Booneville,Ms
    Posts
    505
    I did the day I first got it in and it helped a little but engine power still didn't fill the same you could tell something was wrong. But one day we were trying to drive it from the shop to the house and it went fine still going slow but when I came to a hill I could floor it and still no power and we ended up having to pull it to the house. Someone told me to take it out and replace the converter and someone else said I should check the govenor but thought I'd see what people on here thought.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy