Results 1 to 9 of 9

Thread: Darts left when I lift

  1. #1

    Darts left when I lift

    The car has some pull to the right under acceleration and then darts left when I lift. The car is a 2500 super gas strut front end and four link rear. The front end was just lined up so I'm thinking maybe something in rear. Nothing appears to be broken or bent. This is a new car to me.

  2. #2
    Senior Member DYNO OPERATOR
    Join Date
    Jun 2009
    Location
    Wi
    Posts
    519
    Look for posts by jreiley he had a similar problem not to long ago. maybe some of the responces he got may help you. AL...

  3. #3
    Senior Member RACING JUNKIE TheYellaBrick's Avatar
    Join Date
    Mar 2008
    Location
    Emmett, Idaho
    Posts
    7,334
    Have you checked the chassis square ?
    Is the rear end square with the chassis/front axle line ?
    Sounds like it could be the right side wheelbase is a tad longer than the left.
    TRUTH is HATE
    to those who
    HATE TRUTH

    God Bless our folks in uniform
    "We the People, have your backs"
    http://www.racingjunk.com/profile/279898

  4. #4
    Senior Member MASTER BUILDER
    Join Date
    Jan 2008
    Location
    Yooper
    Posts
    168
    Does the car have a anti roll bar?

  5. #5
    Senior Member RACING JUNKIE TheRabbit's Avatar
    Join Date
    Jan 2007
    Location
    Augusta, Ga.
    Posts
    2,295

    Re: Darts left when I lift

    Quote Originally Posted by jglennfillmore
    The car has some pull to the right under acceleration and then darts left when I lift. The car is a 2500 super gas strut front end and four link rear. The front end was just lined up so I'm thinking maybe something in rear. Nothing appears to be broken or bent. This is a new car to me.
    Lets start from scratch. You said the car was new to you. Did someone have it before you or did you build it? If someone else had it did it drive straight? What have you done to it since you've had it?
    May sound crazy, but if something changes always think back to where the problem started.

  6. #6
    Senior Member EXPERT BUILDER gearhead1011's Avatar
    Join Date
    Jan 2004
    Location
    Shepherdsville, KY
    Posts
    313
    Check the bump steer.

  7. #7
    Senior Member MASTER BUILDER
    Join Date
    Jan 2008
    Location
    Yooper
    Posts
    168
    Quote Originally Posted by gearhead1011
    Check the bump steer.
    X2 J.A.

  8. #8
    Senior Member DYNO OPERATOR
    Join Date
    Aug 2007
    Location
    Lost Creek, WV
    Posts
    533
    Put the car on a set of scales. Check and see how much pre-load is in the chassis.

    TS1955

  9. #9
    had a super gas camaro doing simular thing....finally got to the point where it was swaying all the way down the track. Tore all the rear end suspension apart and found panhard tube bending under load and all heim ends were .002-.004 loose. replaced all ends and converted panhard rod into the newer style x-link setup and was fine after that.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy