Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Yukon HEAT PROBLEM............?

  1. #1
    Senior Member RACING JUNKIE
    Join Date
    Mar 2003
    Location
    Fountain,MICHIGAN
    Posts
    856

    Yukon HEAT PROBLEM............?

    Any GM TECHS out there?
    2004 GMC Yukon 5.3
    Climate Control,Frt.and rear Air and Heat.
    Problem started about a month ago?
    The Temp gauge stated showing a eratic Indication?Sometimes would stay on 160 and others would just move all over?I figured the Sending unit was going bad?But,I n the mean time,My wife said the Heat was'nt RITE?The Blower would NOT Blow at all and the Heat was ONLY when you are going down the Road?Basically.its a Gravity FEED!
    So,Today?I changed the Temp sending Unit,and the Gauge Still does NOT Work?But,Both Heater hoses are HOT?But the bottom radaitor hose is fairly Cool?So,I changed the T/Stat.BUT,that did NOT change a Thing?
    Any IDEAS?
    I figure its a Heater Control switch,under the Dash,MAYBE>?
    Just Not up on the Late Model S#!T?
    Any HELP?Would be GREATLY Appreciated!!!
    THANKS!
    Greg 8)

  2. #2
    sent u pm would take forever to type the process to fix give me a call will walk u through it thanks

  3. #3
    Senior Member EXPERT BUILDER
    Join Date
    Mar 2007
    Location
    Michigan
    Posts
    379
    Have the problem with my 99 yukon all of a sudden can you clue me in on whats wrong ??????
    Blowninjected 540 - when is going fast, Fast enough ?????

    http://www.racingjunk.com/profile/182079

  4. #4
    Senior Member RACING JUNKIE
    Join Date
    Apr 2009
    Location
    kingsport tn
    Posts
    1,735
    as for heater there is a little circut bord in the duct work on pass side held in with 2 or 3 bolts and a wire harness this little booger tells the fan to kick or and blow in low med hi ect try changing it
    CRIMEDOG
    Sam Wood

  5. #5
    Senior Member RACING JUNKIE mopar1968's Avatar
    Join Date
    Dec 2006
    Location
    Abingdon,Virginia
    Posts
    3,579
    Sam that is the blower motor resistor :!:
    Head's up the true drag race!!

  6. #6
    Senior Member RACING JUNKIE TheYellaBrick's Avatar
    Join Date
    Mar 2008
    Location
    Emmett, Idaho
    Posts
    7,334
    Maybe it's 'resisting' too much ?? :P :P
    TRUTH is HATE
    to those who
    HATE TRUTH

    God Bless our folks in uniform
    "We the People, have your backs"
    http://www.racingjunk.com/profile/279898

  7. #7
    Senior Member RACING JUNKIE
    Join Date
    Apr 2009
    Location
    kingsport tn
    Posts
    1,735
    yea i know just had a seinor moment changed about 20 in 2yrs comon problem in all makes
    CRIMEDOG
    Sam Wood

  8. #8
    Senior Member EXPERT BUILDER
    Join Date
    Mar 2007
    Location
    Michigan
    Posts
    379
    Thanks you I'll give it a try.
    Blowninjected 540 - when is going fast, Fast enough ?????

    http://www.racingjunk.com/profile/182079

  9. #9
    Senior Member RACING JUNKIE
    Join Date
    Apr 2009
    Location
    kingsport tn
    Posts
    1,735
    also after losts of thinking these are dexcol motors (dexcol coolant) might have restricted coolant passages because dexcool does bad things to orings and other parts try back flushing and plain old flushing and use your favoritee brand of anti freeze to replace because after talking to a prestone rep a couple years ago any antifreeze made in the last 6 or so years has been formulated to modern standards with out nasty results of dexcol and some other factory coolants
    CRIMEDOG
    Sam Wood

  10. #10
    Senior Member EXPERT BUILDER
    Join Date
    Mar 2007
    Location
    Michigan
    Posts
    379
    I dont have a problem with the blower motor works fine low' medium' fast my Problem is the mode switch for defrost, feet, or vent switch don't do anything or let any heat into the vehical, nor does the A/C botton works anymore nor the recirculation switch works any ideas
    Blowninjected 540 - when is going fast, Fast enough ?????

    http://www.racingjunk.com/profile/182079


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy