Results 1 to 5 of 5

Thread: Ticking noise-cant figure out- Any Help?

  1. #1

    Ticking noise-cant figure out- Any Help?

    I have a 4.6L w sohc motor that has developed a ticking sound from what sounds like its coming from the pass- side valve cover. It only occurs after the engine is good and warm. I have change oils, a few times. I use a motorcraft filter. I have changed the timing chains, followers, chain tensioners, and the pass-side lash adjusters and still....nothing? And I changed the idler pulley. Anyone have any other good ideas as to what this could be? I am at a complete loss. :?:

  2. #2
    Tinman what year is the Mod Motor, is it a 3 valve with cam phasers

  3. #3
    Senior Member RACING JUNKIE
    Join Date
    Apr 2009
    Location
    kingsport tn
    Posts
    1,735
    my 5.4 in my expidition does it and its an annoying exhust leak
    CRIMEDOG
    Sam Wood

  4. #4
    It is a 2000 mustang with a motor pulled from a similar year crown vic. Or it may have been a marquis....not positive. I took it in on trade and not long after I had it, it started ticking. But only after it is good and warmed up? Its not the three valve.

  5. #5
    Pretty sure it isnt a exhaust leak. It sounds different than any exhaust or leaky header I have had. I dont think its a noisy injector either.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy