Results 1 to 7 of 7

Thread: small silver pieces in oil filter

  1. #1

    small silver pieces in oil filter

    i just changed my oil and cut the filter open.There is alot of silver flake looking pieces in it. oil had a silver tint to it also.Its a shaffiroff 565 with only 10 passes.this is the first oil change.Is this normal or do i have a problem.I use lucas 20-50 racing oil.oil pressure was 55-60.thanks Art

  2. #2
    Senior Member RACING JUNKIE
    Join Date
    Jan 2006
    Location
    La.
    Posts
    2,890
    I'm thinking you have a problem, that silver is probably bearing flakes, indicating hot bearings, maybe not enough clearance.

    JMO

    Zip.

  3. #3
    Senior Member RACING JUNKIE
    Join Date
    Dec 2004
    Location
    austin texas
    Posts
    729
    U have described a noticable amount, that is bad and only going to get worse. All the material caught in the filter has already been ran threw all your .001-.003 clearances and scared them up, as well as scuff your cylinder walls each time the piston goes up and down with contaminated oil.

    But for most engine builders this is typical, and the engine tears up very shortly after.

  4. #4
    thanks guys, so it would be a good idea to pull it out and have it looked at?this sucks

  5. #5
    Senior Member RACING JUNKIE
    Join Date
    Jan 2006
    Location
    La.
    Posts
    2,890
    Quote Originally Posted by Autotek2
    thanks guys, so it would be a good idea to pull it out and have it looked at?this sucks
    Absolutely don't make another pass with it, or it could be your last one as the bearings may spin or eat the crank.

    JMO

    Zip.

  6. #6
    Senior Member RACING JUNKIE TheYellaBrick's Avatar
    Join Date
    Mar 2008
    Location
    Emmett, Idaho
    Posts
    7,334
    X2 all the above !! :shock: :shock:
    TRUTH is HATE
    to those who
    HATE TRUTH

    God Bless our folks in uniform
    "We the People, have your backs"
    http://www.racingjunk.com/profile/279898

  7. #7
    Member MASTER JOURNEYMAN
    Join Date
    Aug 2007
    Posts
    45
    Since it's prolly not hurt to the point of no return "yet". I'd call Scott's shop and tell them what you found...I know most shops don't guarantee racing engines but since you caught this early and it hasn't failed they may take care of this and besides they may want to know what failed on it so they can be on the look out for this. After all they have a reputation at stake....they would probably even cover shipping just to find out what is going on with it.
    One other thing...I have a friend that bought one of their 496 short block assemblies, it prolly had a season + passes on it. He just had it rebuilt by a local shop and they found signs of this on one of the journals and bearings when they took it apart.....it wasn't bad but he said you could tell things appeared to be tighter than they were supposed to be.....I believe they had to take it down .010 or more because of that...


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy