Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Nitrous problems

  1. #1

    Nitrous problems

    I have a new 565" engine in a dragster, 15:1 compression, , approx. 900 HP. I bought a new Zex perimeter plate system, installed exactly by the instructions, filled the bottle, bought a gauge to make sure I am over 950 psi, also bought a bottle heater. I can not get the system to work properly on any power level, I installed a seperate fuel cell and Holley blue pump and regulator for the NOS, use C-16 gas in it, set the pressure at 6 like the directions stated. I also installed a separate button to activate the system and purge it along with running it thru a separate timer. I set the timing at 29, when the system is armed and the button is hit it will slowly climb to 4500 and then just stay there like its hitting the MSD chip, which it is not, it has a 7500 high chip in it, but will not rev up no matter what shot jets I put in from 100 to 250HP, they all act the same, tried a friends NOS plate and jets, works exactly the same, motor will not rev up, I take it to 3000 and hit the button and it only slowly goes to 4500, will not scream to the chip like I see other systems do, I even tried lowering the fuel pressure to 5 and then 4, still acts exactly the same???. This system was brand new in the box, nothing was used in it, I even tried another bottle, still the same, whats wrong here????????????????. System sounds like it is flooding the engine out, checked the plate with the carb off, first shot gas thru it, then NOS, then both together, all seemed to work fine. I originally had the main system on alky, even switched it over to 112 race gas, with a different carb, works exactly the same, tried by-passing the relay and timer by hitting the solenoids with 12 volts direct, worked exactly the same, can-not find anything wrong, please help.

  2. #2
    Senior Member RACING JUNKIE
    Join Date
    May 2003
    Location
    Coldwater, MI
    Posts
    2,998
    Did you check the timing while testing the nitrous ? Maybe its retarding the timing more then you think ??

  3. #3
    Administrator RACING JUNKIE
    Join Date
    Mar 2004
    Location
    Maine,USA
    Posts
    1,208
    Sounds like the torque converter is broke
    There Is 1 Thing Better Than Cubic Inches,,,More Of Them

  4. #4
    Timing is not moving, checked it several times, there is no retard box connected yet, I just retarted the overal tining to 29, have tried from 29 to 36, all work the same, tried 2 different converters, the one in it now is brand new with zero passes on it, other one ran 4.98 on motor, this one should be a tenth faster. Car runs fine when not trying to spray.

    Next idea????????????????????????

  5. #5
    Senior Member RACING JUNKIE
    Join Date
    Mar 2003
    Location
    Ohio
    Posts
    936
    I want to make sure I am following along. We have the following

    1) NOS Solenoid getting 12V when timer activates
    2) Fuel system/solenoid getting 12V when timer activates
    3) Purge Valve getting 12V when purge button is pushed

    Is your arm switch seperate from your purge switch. Was not real sure they way I was reading that?

    NOS/Fuel mixture is accurate for the shot being applied?
    Thank you to all our sponsors:

    Racetech Race Cars
    V's House of Horse Power
    Intensity Race Products
    Vickers Transmissions
    Abruzzi Converters
    J&J Engine Diapers

  6. #6
    Yes, arm switch separate from purge switch, both run off the NOS relay, once armed, the system either runs off the timer, or the push button. NOS/fuel mix is as posted by the CO. as far as jetting, and fuel pressure of 6psi and 950 NOS. min. are per them also. I have not changed anything from their recommendation, except when i put my friends NOS plate on with his jetting for a 125 shot, my jets would not fit his plate, system worked the same, made no difference at all, only thing I have not replaced are the solenoids, which is the next thing to try. Hows this for an idea, what would happen if the factory mis-labeled the (2) solenoids, and the gas one was really the NOS., and the NOS one was the fuel??? there are only stickers stuck to them, they are not permanently engraved or anything???????.

  7. #7
    Senior Member RACING JUNKIE
    Join Date
    Mar 2003
    Location
    Ohio
    Posts
    936
    I guess anything is possible but how odd would that be. I just wonder if your jet for the NOS side is mismarked and you are not getting the NOS you need? Have you tried a different NOS jet?
    Thank you to all our sponsors:

    Racetech Race Cars
    V's House of Horse Power
    Intensity Race Products
    Vickers Transmissions
    Abruzzi Converters
    J&J Engine Diapers

  8. #8
    System is fixed, was at the track tonite, first problem was that the regulator for the gas side was creeping to 12 to 15 psi, which is what was being shot into the motor at the initial hit, replaced the regulator with a return style that does not "deadhead", this one holds at 6 all the time, next I took out the NOS inlet fitting that has a filter inside, found a rather large piece of teflon tape inside blocking it off, I do not have any tape on this car anywhere, have no idea where it came from, someone said maybe it was inside the bottle or maybe the shop that filled the bottle used it, not sure, took it out, took car out, worked fine, picked up 2 tenths running only a few seconds down the track.

  9. #9
    Senior Member RACING JUNKIE
    Join Date
    May 2006
    Posts
    2,044
    Glad to hear you got it fixed.
    Turns out that filter is there for a reason eh?
    You better be glad it caught that tape, let that shiit get in a solenoid or a spray bar, oh lord.....I'd put it back in there.
    ***IN GOD WE TRUST***

  10. #10
    The filter is inside, and i am thinking of buying an additinal in-line filter so I don't have to keep taking out the fitting from the sol.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy