Results 1 to 4 of 4

Thread: Has anyone used Dutchman Good or Bad

  1. #1
    Junior Member SHOW GUEST
    Join Date
    Oct 2009
    Posts
    2

    Has anyone used Dutchman Good or Bad

    I have Dutchman axles in the housing of my nova it is a ford 9in 35 spline I was going to get a Dutchman 3er member but I am looking for some feed back on there quality and reliabilty, just trying to match all components

  2. #2
    Senior Member RACING JUNKIE mytmouz's Avatar
    Join Date
    May 2006
    Location
    Pelahatchie, MS
    Posts
    983
    I have a set in my street ride, and I have had them in the past on other stuff. (Already in them when I got them) No problems with anything...
    If you think nobody cares, try missing a payment...

  3. #3
    Senior Member DYNO OPERATOR
    Join Date
    Aug 2005
    Location
    Rifle Colorado
    Posts
    585
    I had a set in my ol '63 Nova with a 9". I probably put 1500+ 1/4 mile runs on them running high 10's low 11's and never had an issue. They were still in it when I sold the car....
    Johnny

  4. #4
    Junior Member SHOW GUEST
    Join Date
    Oct 2009
    Posts
    2
    Cool thanks for your help, I think I will go ahead order from them a new 3rd member


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy