Results 1 to 3 of 3

Thread: 99 s-10 blazer brake light?

  1. #1
    Senior Member SENIOR BUILDER
    Join Date
    Feb 2005
    Location
    LAWTON MI
    Posts
    113

    99 s-10 blazer brake light?

    Not sure what to look for next need help
    Rear left side brake light not working
    Works when the right side turn signal is on but if the turn signal is turned off I lose the left brake light
    Left turn also works fine
    I have checked all the bulbs and wiring in the rear looks good
    I have also removed all trailer wiring did not help

  2. #2
    Senior Member RACING JUNKIE oldandtired's Avatar
    Join Date
    Dec 2008
    Location
    Sugar Hill, GA
    Posts
    1,368
    I had an issue similar on a 66 Nova and it was a poor ground causing feedback thru the blinker circuits. Something else to check. Dave
    Dave
    http://www.racingjunk.com/profile/343797
    "All that is necessary for the triumph of evil is for good men to do nothing" Edmund Burke

  3. #3
    Senior Member RACING JUNKIE TheYellaBrick's Avatar
    Join Date
    Mar 2008
    Location
    Emmett, Idaho
    Posts
    7,334
    I've seen turn sig switches do some really weird stuff to the lighting system......You can chase the problem for DAYS and it'd be that lousy signal switch ! :x :x :x :x
    TRUTH is HATE
    to those who
    HATE TRUTH

    God Bless our folks in uniform
    "We the People, have your backs"
    http://www.racingjunk.com/profile/279898


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy