Results 1 to 4 of 4

Thread: Blower motor question 2000 Chevrolet Crew cab Dually

  1. #1
    Senior Member RACING JUNKIE
    Join Date
    Sep 2007
    Posts
    4,143

    Blower motor question 2000 Chevrolet Crew cab Dually

    The blower motor on my truck stopped working last week....checked the fuse and it was good. Came out a few minutes later and it worked fine....quit again in the middle of the week, yesterday it worked fine. Today it doesn't work.

    WTF should I look for as the problem? ...I'm thinking maybe a bad connection ?? Any help is appreciated greatly.

  2. #2
    Senior Member EXPERT BUILDER gearhead1011's Avatar
    Join Date
    Jan 2004
    Location
    Shepherdsville, KY
    Posts
    313
    Probably the blower motor. Next time it does that try thumping the blower, if that makes it come on replace it.

  3. #3
    Senior Member DYNO OPERATOR
    Join Date
    Feb 2009
    Posts
    510
    I think there is a resetable relay in there somewhere in those trucks. I think I have heard that somewhere. Age is getting to me.

    Also, does it do it on all speeds or just one or two of them?

  4. #4
    Senior Member RACING JUNKIE
    Join Date
    Sep 2007
    Posts
    4,143
    Quote Originally Posted by gearhead1011
    Probably the blower motor. Next time it does that try thumping the blower, if that makes it come on replace it.
    That's it. Did exactly that...thump with the fist and it came on.

    Thanks


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy