Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: engine trouble

  1. #1

    engine trouble

    i have a sbc 383 that the outer ring on the balancer has come a apart at high rpm say around 6900.the rest of the balancer stayed on the motor and the motor was steal running before i shut it down.do you think there might be some interal damage?

  2. #2
    Senior Member RACING JUNKIE
    Join Date
    May 2006
    Posts
    2,044
    I doubt it.

    Pull the old one off and stick a new on there and go racing.
    ***IN GOD WE TRUST***

  3. #3
    Senior Member RACING JUNKIE
    Join Date
    May 2003
    Location
    Coldwater, MI
    Posts
    2,998

    Re: engine trouble

    Quote Originally Posted by greenone60
    i have a sbc 383 that the outer ring on the balancer has come a apart at high rpm say around 6900.the rest of the balancer stayed on the motor and the motor was steal running before i shut it down.do you think there might be some interal damage?
    I've seen this happen before, all has been but there was 1 time I seen it cause a issue. Motor started to have a vibration after, if thats the case shut it off and pull it apart
    David Lanning
    IHRA NHRA 387B

    Fleenor Racing Transmission
    419-280-1406
    Lanning Electric
    Complete Drag Car Wiring
    APD Race Engines
    www.apdracing.com

  4. #4
    Senior Member RACING JUNKIE
    Join Date
    Jun 2003
    Location
    Hobbs, NM
    Posts
    842
    I'd pull the filter, cut it open and check for any bearing material or metals. Just to be on the safe side. Won't take but a few minutes and $10.00 filter.

  5. #5
    Senior Member MASTER BUILDER
    Join Date
    Oct 2007
    Location
    Staunton,VA.
    Posts
    249

    balancer

    x2 what they said.

    Kris

  6. #6
    Senior Member MASTER BUILDER
    Join Date
    Oct 2007
    Location
    Staunton,VA.
    Posts
    249

    balancer

    one more thing check the timing again. if you had a stock balancer the ring may have slipped alittle be fore it came off causing timing to be off. Let us know.
    Kris

  7. #7
    Senior Member DYNO OPERATOR
    Join Date
    Aug 2007
    Location
    Lost Creek, WV
    Posts
    533
    At 6900 rpm's ya might want to get an SFI approved balancer. JMO

    TS1955

  8. #8
    Senior Member RACING JUNKIE
    Join Date
    Sep 2007
    Posts
    4,143
    Sprint cars run with NO BALANCER AT ALL...but their crank most likely cost a bit more than yours.

  9. #9
    thanks guys for the info, and yes iam getting a sfi balancer.

  10. #10
    Senior Member RACING JUNKIE THERATTLER's Avatar
    Join Date
    Sep 2003
    Location
    LICKSKILLET , MISSISSIPPI
    Posts
    1,474
    I HAVE BEEN RUNNING WITH NO BALANCER FOR YEARS , JUST HUB FOR BOTTOM PULLY
    ***IN GOD WE TRUST***GOD BLESS AMERICA******


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy