Results 1 to 2 of 2

Thread: C-4 reverse servo keeps breaking any ideas why?

  1. #1
    Junior Member SHOW GUEST
    Join Date
    Jan 2005
    Posts
    2

    C-4 reverse servo keeps breaking any ideas why?

    I have a small block ford mustang with a C-4 3500 converter stock internals with a B&M shift kit.
    I been running this set up for 7 years in this car with no trouble until the servo and the application fork for the reverse band broke
    since then it has broke three times after i rebuild the trans changed the valve body with a different stock valve body readjusted the bands three times.the application fork is broken right down the middle like it has been broken by the servo pushing on it to hard.

    I did not find anything that looked out of the ordinary inside the trans

    has any one ever had this problem or does any body have any idea why this would happen

  2. #2
    Senior Member RACING JUNKIE
    Join Date
    May 2006
    Posts
    2,044
    You might try posting this in the transmission section of this forum>

    Cp
    ***IN GOD WE TRUST***


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy