Results 1 to 1 of 1

Thread: sway bar end links

  1. #1
    Junior Member SHOW GUEST
    Join Date
    Jun 2007
    Location
    boise idaho
    Posts
    6

    sway bar end links

    went to the bogus basin hill climb this weekend and on my first run i slid off (front end pushed) and buried the nose into the hill side. when i got the car to the pit area i found the end link of the rear sway bar had pulled through the eye of the bar,the lower bushing and washer were gone but the bolt and nut were still there. this is the third time this has happened. the first time it was the front sway bar and resulted in a very nasty accident. however i think it was my fault in material used. the last two times its been the rear bar... has anyone else had this kind of problem or could it be a design flaw on my part. the end links on the rear are mounted solid to a bracket (with a bushing on each side of the end link) that is bolted to the body. where as the front uses a 6 or 8 in bolt and spacer with 4 bushings per side the rear uses a 3 or 4 in bolt and 2 bushings per side. do i need to put the rear back to stock design to allow more movement? any ideas will be apprecated.....thanks tao

  2. Racing Junk


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy