Racingjunk Forums

Racingjunk Forums (https://www.racingjunk.com/forums/index.php)
-   Engine Tech (https://www.racingjunk.com/forums/forumdisplay.php?f=9)
-   -   motor poping (https://www.racingjunk.com/forums/showthread.php?t=17606)

jl4020 06-20-2007 06:55 PM

motor poping
 
can some one help me mind my easy fix. i have inquird a poping noise at high rpm. i thought i might have water in fuel but carb,fuel pump and filter was clean. iam think that if it was a bad valve spring it would do it threw out rpm.? right or wrong? any way to test msd box? it a big block chev

topsportsman1 06-20-2007 07:07 PM

What MSD Ignition box you got? How high rpm are you talking about?

jl4020 06-20-2007 07:14 PM

msd 7al well some where around 6000 and up i have a 7000 pill.in it

topsportsman1 06-20-2007 07:20 PM

7AL?? 2 or 3?

jl4020 06-20-2007 07:25 PM

my bad it a 2

topsportsman1 06-20-2007 07:43 PM

Its possible the 7al2 could be going away,the 7al2 is about the same caliber box as the 6al,which is about half the caliber as a 7al3

I'd sooner think you was having issues with your box,or the add on box for the rev limiter,maybe unplug the rev limiter and see if the problem goes away,other than that,I'd say either upgrade the box or ship it back to MSD and have it checked out

Also you could be having tachometer issues causing it to cut out at higher rpm's

davis419b 06-20-2007 08:10 PM

What kind of fuel do you run? I know you said it was clean but i still want to know. Also what compression do you run?

billhendren 06-21-2007 05:19 AM

You may want to check your valve springs,also make sure your mag pickup wires are separated from the coil orange and black leads.also check the polarity on the mag pickup.to do this look at where your timing is set,unplug the dist and take two short wires.plug one end into the dist and cross the wires before plugging them into the wire loom.start the engine and see if the timing advanced or retarded.the correct position is the retarded one.Bill

jl4020 06-21-2007 01:08 PM

vp 110 it 13to1 it just started it last weekend never had a prolbem till then . ithought if it was valve spring it would do it all the time?

bjuice 06-21-2007 03:24 PM

i have to ask..what did you run before then ?...(fuel)

thanks brian


All times are GMT -8. The time now is 10:25 AM.