Racingjunk Forums

Racingjunk Forums (https://www.racingjunk.com/forums/index.php)
-   Tuning & Diagnostics (https://www.racingjunk.com/forums/forumdisplay.php?f=22)
-   -   Ticking noise-cant figure out- Any Help? (https://www.racingjunk.com/forums/showthread.php?t=29065)

tinman80 10-19-2010 06:25 PM

Ticking noise-cant figure out- Any Help?
 
I have a 4.6L w sohc motor that has developed a ticking sound from what sounds like its coming from the pass- side valve cover. It only occurs after the engine is good and warm. I have change oils, a few times. I use a motorcraft filter. I have changed the timing chains, followers, chain tensioners, and the pass-side lash adjusters and still....nothing? And I changed the idler pulley. Anyone have any other good ideas as to what this could be? I am at a complete loss. :?:

smoken69 10-20-2010 09:05 PM

Tinman what year is the Mod Motor, is it a 3 valve with cam phasers

dragonmaster093 10-20-2010 09:58 PM

my 5.4 in my expidition does it and its an annoying exhust leak

tinman80 10-21-2010 04:28 PM

It is a 2000 mustang with a motor pulled from a similar year crown vic. Or it may have been a marquis....not positive. I took it in on trade and not long after I had it, it started ticking. But only after it is good and warmed up? Its not the three valve.

tinman80 10-21-2010 04:34 PM

Pretty sure it isnt a exhaust leak. It sounds different than any exhaust or leaky header I have had. I dont think its a noisy injector either.


All times are GMT -8. The time now is 04:08 AM.