Racingjunk Forums

Racingjunk Forums (https://www.racingjunk.com/forums/index.php)
-   Transmission (https://www.racingjunk.com/forums/forumdisplay.php?f=14)
-   -   Torque converter installation question and problem (https://www.racingjunk.com/forums/showthread.php?t=20177)

lmccoll 03-10-2008 05:16 PM

Torque converter installation question and problem
 
I have SBC with a TH350 transmission. We changed the torque converter out. When I installed it, it rotated over easy and seemed to be in the transmission correctly.

After installing the engine and bolting up the transmission, I notice the torque converter will turn (not bolted to flex plate yet), but it is very hard to turn. In the past when I put in a converter, I could turn them by hand to line up the bolt holes. Now, I have to put a little force behind it. Both the converter and crank are new.

It appears the "nub" in the front of the converter that fits in the end of crankshaft is really tight. It is not hitting or rubbing anywhere else. With no bolts in the converter, the bolting flanges are about a small finger width from the flexplate which I think is about normal.

Is this a problem?

Thanks for any help.

Larry

ssym 03-11-2008 03:23 AM

Larry,

Fresh paint on the converter can make it more difficult to turn without the bolts in.

Your spacing sounds too big. You should have 1/8 to 3/16 inch between the mounting lugs and the flex plate with the trans in place and torque converter not bolted up. This is important for pump engagement. Use hardened washers or spacers to make this accurate.

topcat572 03-11-2008 08:20 AM

tight
 
All good points above, just seems like its getting stuck on the hub and the hole in the flywheel.


All times are GMT -8. The time now is 06:08 PM.