PDA

View Full Version : non racing related... 98 dakota problem


mikesramblur
07-12-2011, 03:52 PM
my dd 98 dakota 318 4x4. its been sitting for about 3 weeks, replaced battery on weekend and now wont idle. replaced tps twice. (first fell apart). didnt help. starts and runs fine but no idle. tested plug as service manual says. have 5 volts at plug. any ideas would be good.

thanks.

gearhead1011
07-12-2011, 06:12 PM
Assuming the problem started after the battery was replaced it sounds like it may have lost the idle adaptive. I would start with cleaning the throttle body. Usually they get coked up around the area where the throttle blade is at closed throttle. You can use a soft bristle brush and some spray carb cleaner. You will have to hold the throttle open while cleaning. DO NOT use a wire brush, a cheap toothbrush works well. After that take it out and drive it getting it up to 45 MPH then slowing down at least 3 times. If that doesn't do it you could have a problem with anything from the IAC to the PCM and considering the expense of guessing wrong you might be better off to have a professional diagnose it for you.

mikesramblur
07-13-2011, 01:45 AM
ok, i'll get some spray cleaner today and try that tonite. try cheap first. had a look at the blades, their filthy black dirt on there.

gearhead1011
07-13-2011, 05:40 AM
Make sure to clean the bore, that's where the problem usually is, as the crud builds up it effectively closes the throttle which lowers the idle speed. The computer (PCM) compensates for it but when the battery goes dead or you disconnect it the adaptive strategy is lost.

mikesramblur
07-14-2011, 01:33 PM
throttle body cleaner is a good thing. worked just fine and idles like new again. even took away a little stumble it had for a longtime.

thanks