PDA

View Full Version : My V8 S-10 (lots and lots of pics)


Alanky
03-14-2008, 11:44 AM
Hello! Im a newbie here and figured I would show off my S-10. Let me know what you guys think!

http://i205.photobucket.com/albums/bb305/Alanky/84%20s-10/Frnt.jpg

http://i205.photobucket.com/albums/bb305/Alanky/84%20s-10/1.jpg

http://i205.photobucket.com/albums/bb305/Alanky/84%20s-10/n.jpg

http://i205.photobucket.com/albums/bb305/Alanky/84%20s-10/FrontHoodopen.jpg

The above pictures are when it had a 355 in it. This winter I tore it all apart and put a 406 together for it. Havent drove it yet, but I hope I didnt tear apart a perfectly good running truck for nothing! I hope the 406 is a noticeable difference. I have had plenty of 350's, but this is my first experience with a 400.

http://i205.photobucket.com/albums/bb305/Alanky/406%20build/11-14-07_1708.jpg

http://i205.photobucket.com/albums/bb305/Alanky/406%20build/11-14-07_1627.jpg

http://i205.photobucket.com/albums/bb305/Alanky/406%20build/Crank1.jpg

5.7 Rods
http://i205.photobucket.com/albums/bb305/Alanky/406%20build/Pistons1.jpg

http://i205.photobucket.com/albums/bb305/Alanky/406%20build/Rockers.jpg

Out with the 355:
http://i205.photobucket.com/albums/bb305/Alanky/406%20build/Pulling2.jpg

406 sat in:
http://i205.photobucket.com/albums/bb305/Alanky/406%20build/Copyof100_0677.jpg

http://i205.photobucket.com/albums/bb305/Alanky/406%20build/MVC-005F-1.jpg

http://i205.photobucket.com/albums/bb305/Alanky/406%20build/MVC-014F.jpg

http://i205.photobucket.com/albums/bb305/Alanky/406%20build/WTF.jpg

http://i205.photobucket.com/albums/bb305/Alanky/406%20build/CopyofIMG_0688.jpg

http://i205.photobucket.com/albums/bb305/Alanky/84%20s-10/CopyofIMG_0698.jpg

Back on its wheels. I put a billet grill in it, but I think Im going to have to paint it black. The aluminum radiator dominates it!

http://i205.photobucket.com/albums/bb305/Alanky/84%20s-10/CopyofIMG_0686.jpg

http://i205.photobucket.com/albums/bb305/Alanky/84%20s-10/CopyofIMG_0687.jpg

hammertime
03-14-2008, 12:34 PM
Very nice !!

lookingaround
03-14-2008, 01:40 PM
nice ride. you should notice a big difference in the two motors

nofear57
03-14-2008, 01:44 PM
Very nicely done......406 even nicer! I love the black paint and stance you gave it. Its not over done or to busy which some people do. The billet grill works perfect with the package,it off sets the black nice. But yes the rad is over powering. You could paint the rad black to hide it but that might work against the cooling system. Maybe a loovered piece of black tin between the grill and rad might work,just a quick thought? Where did the rims come from,they sure look good? These trucks tubbed are very cool,any thoughts of that in the future?

Alanky
03-14-2008, 02:39 PM
nice ride. you should notice a big difference in the two motors

Thanks! I hope I do. I was really happy with the way the 350 ran. I had this 400 block in the corner of the garage for about 5 years. I pulled it out and was going to sell it, but a buddy of mine said I should go ahead and build it and sell the 350 instead. So I did :D


Very nicely done......406 even nicer! I love the black paint and stance you gave it. Its not over done or to busy which some people do. The billet grill works perfect with the package,it off sets the black nice. But yes the rad is over powering. You could paint the rad black to hide it but that might work against the cooling system. Maybe a loovered piece of black tin between the grill and rad might work,just a quick thought? Where did the rims come from,they sure look good? These trucks tubbed are very cool,any thoughts of that in the future?

Thanks! It actually needs paint really bad. Thats next! The stance is a 4 inch drop in the front and a 5 inch drop in the rear. I thought about painting the radiator, but figured that would hold the heat in more. I think I am just going to leave it alone. I figure after a few years the aluminum will dull and start to turn anyway. So for now it just looks like I mean buisness with that big ole aluminum radiator filling up all of the open area of the core support. :lol: The rims are off a 2003 S-10 ZQ8 package truck. I actually owned another S-10 a few years back that was tubbed and setup for a big block. I had just finished making this one a V8 with the 355 and was not ready for another project right away. I never did anything with it besides let it sit beside the garage. One day somebody knocked on my door and offered almost double what I had in it, so I had to let it go. I kick myself now and really wish I would have kept it. I may never tub this one, but I wouldnt mind having another tubbed S-10 in my future. Infact I bought a bed off an S-10 that hit the wall at the track, so I have a tubbed bed sitting behind the garage.....just incase!

olds48
03-14-2008, 10:14 PM
I think the paint looks great!!!Beautiful truck!!!You should be proud.

mytmouz
03-14-2008, 10:18 PM
8)

Alanky
03-15-2008, 03:05 PM
I think the paint looks great!!!Beautiful truck!!!You should be proud.

It is shiney, but it was re-painted right before I got it back in 1999. They didnt know what they were doing or they rushed it. There is crows feet and fisheyes all over the roof and a run on the bottom of the drivers door. Now the paint is lifting in spots and it is going to need a cab corner real soon. But yes I am proud of the truck. It has come a long way since I have had it. A neighbor down the street made me an offer on it today, but I cant let this one go. Hell I havent drove it with the 406 yet! Plus if he bought it I would be seeing it right down the road all the time and that would stink!

olds48
03-15-2008, 05:55 PM
Oh man.If you sell that truck,then have to watch your neighbor drive it by your door... :( :( :(

Alanky
03-15-2008, 10:31 PM
Right! Thats why he wouldnt get it even if I did want to sell it. I highly doubt I will ever get rid of this truck.

qtrmile2
03-16-2008, 04:32 AM
Very Nice. You should be very proud of your truck, Nicely done.
How's it run? Have you taken it to the track or just street drive it.

Alanky
03-16-2008, 09:56 PM
Never taken it to the track. Just street drove it with the 355. I might take it to the track one night to see what the 406 does. Friend of mine has a 55 chevy with a 355 in it to. He runs in the 7's at the local 1/8th mile track and I could keep up with him pretty well with my 355. From a stop he would get me because mine dont hook, but from a roll we pretty much stay side by side. He doesnt know about this 406 swap either. :lol: Hopefully this is a great improvement over the 355 I had and hopefully I can suprise him sometime. :wink:

Alanky
03-16-2008, 10:00 PM
Here is a idle clip of the old 355. I went with a smaller cam in the 406 to keep it as more of a sleeper, but Im going to miss the sound!

http://i205.photobucket.com/albums/bb305/Alanky/Videos/th_e2e5bbfa.jpg (http://s205.photobucket.com/albums/bb305/Alanky/Videos/?action=view&current=e2e5bbfa.flv)

Alanky
03-20-2008, 10:24 PM
Well Im in love all over again. :D I havent even had it past half throttle yet and I am still tickled pink. Even taking it easy I can tell there is a lot more power and a TON of torque under that pedal. With the 355 at about a 30 MPH roll in 1st it would haze the tires and spin midway through second. I was coasting down my street at about 20 and just gave the pedal a good half throttle stab and it made the tires squeek. Should be interesting when I finally get on it. I didnt think gaining only about 56 cubic inches would make that noticable of a difference. No more cooling problems either. New radiator is great! Never over 160 idleing in traffic and never over 140 driving. Also met up with another V8 S-10 while I was out. He was kinda stupid though. He saw me behind him ( I dont have my hood on yet) and he mashed his throttle. He was all the way sideways on a 2 lane back road and when he lifted he was still sideways and spinning. So needless to say it hooked and jerked hard to the left. He about lost it. When I finally got up next to him he nailed it again and it poped through the carb and died. He probably thought I was a sissy since he kept showing off and all I was doing was crusing :D So far ripping out a perfectly good running 350 to put this 406 in was worth it!

olds48
03-21-2008, 12:41 PM
Cool!!!Sounds good.Glad to hear you know how to enjoy a hotrod without endangering everyone around you,too.Have fun!!!

Alanky
03-21-2008, 09:11 PM
Cool!!!Sounds good.Glad to hear you know how to enjoy a hotrod without endangering everyone around you,too.Have fun!!!

Thanks! Yea im not an idiot when it comes to driving this thing. I did have some fun today though, but it was on a big wide major highway. Still havent had it to the floor yet, but I made it to about 3/4 throttle today. I broke it in before I drove it, but I still like to take it easy on a new motor for awile. Not to toot my own horn, but this thing is a torque monster. Played with a newer model mustang today. Passed him like he was backing up without even shoving it to the carpet. :D That was a pretty good feeling.


I do have one BIG issue though. Starting this thing. I have to put a charger on it and put it on atleast the 40 amp setting to spin it over fast. With a volt meter on it the battery goes from 12.48 to 8.67 volts during cranking. I would find it hard to believe the brand new starter is bad, but I guess it could be. Or maybe I should have got a 3hp gear reduction starter instead of a plain ole 2hp mini starter. I havent checked the compression yet, but I have a feeling its up there, so that might be the problem to. The battery is in the bed and ran/grounded all with 4 gauge wire. Thinking of going to 2 gauge on all of that to. It cant hurt. Sucks not being able to shut it off anywhere. Like today I was biting my fingernails with the gas gauge sitting on E. I had to make it home. :D While I was so worried about my gas guage I stopped looking at the others. I turned on my street and realized it was creeping up to 200 degrees. No big deal, but it has been running at 140-160. Pulled in the driveway, got out and the fans were not running. My new relay crapped out on me, so I put the old used and abused one that was in it with the 350 back in and cured that problem.

olds48
03-22-2008, 09:31 AM
How long are your battery cables?I ran 2 gauge on mine.They were about 18 feet long and had no problems.If you can,find some welding cable to use instead of regular battery cables.The copper strands in the welding cable are alot finer and there are more of them.Electricity doesn't flow thru a wire,it travels on the outside of the conductors.Strange but true.The more individual strands the lower the voltage drop.That is why cars can get away with such high loads on smaller stranded stranded wires,whereas the wiring in your house(solid conductors)have to be so much larger in diameter.I had a problem with a hard start condition one time and found that the terminal on the solenoid that the battery cable hooks to was loose on the solenoid itself.Big voltage drop there.

Alanky
03-22-2008, 08:13 PM
The cables are probably 12-14 foot long. I replaced the longest one from the one side of the disconnect to the starter with 2 gauge welding wire today since I happened to have some. Seemed to help a little. Now I need about 5 foot more to go from the battery to the other side of the disconnect and some small pieces to re-do the grounds.

Tod74
03-22-2008, 09:30 PM
good looking truck. I have had two mild 406 sm blks in street cars...just flat top pistons with hyd cams , and I can tell you you will love the torque.

olds48
03-23-2008, 11:04 AM
What kind of disconnect do you have and how old is it?Some of them are not rated for the amperage it takes to start a car.746 watts equals one hp.Watts divided by voltage equals amps.So..if you have a mini starter rated at 2 hp that is 1492 watts.1492 watts divided by 12 volts is 124 amps!!If your voltage drops to 8 volts(which is not that uncommon if you watch your gauge) it would be 184 amps.ALOT of the cut-off swithches people use are only rated at 20 amps continous and 200 amps intermittent.Not much of a switch considering all the electronics some guys run.Water pump,elec fan,ign box(which is not much),1 or 2 fuel pumps,and then when you pull your lights on at night...20 amp switch barely covers your head/tail lights.doesn't take long to max out one of those babies.Check your switch.If it being overworked it could be losing alot of voltage where it has been overheated from over-amperage.Might be cheaper than buying alot of cable.Moroso makes a severe duty switch rated at 2,000 amps intermittent and 300 amps constant.Goes for about $60.Just a thought :?

Tod74
04-26-2008, 08:28 PM
What kind of disconnect do you have and how old is it?Some of them are not rated for the amperage it takes to start a car.746 watts equals one hp.Watts divided by voltage equals amps.So..if you have a mini starter rated at 2 hp that is 1492 watts.1492 watts divided by 12 volts is 124 amps!!If your voltage drops to 8 volts(which is not that uncommon if you watch your gauge) it would be 184 amps.ALOT of the cut-off swithches people use are only rated at 20 amps continous and 200 amps intermittent.Not much of a switch considering all the electronics some guys run.Water pump,elec fan,ign box(which is not much),1 or 2 fuel pumps,and then when you pull your lights on at night...20 amp switch barely covers your head/tail lights.doesn't take long to max out one of those babies.Check your switch.If it being overworked it could be losing alot of voltage where it has been overheated from over-amperage.Might be cheaper than buying alot of cable.Moroso makes a severe duty switch rated at 2,000 amps intermittent and 300 amps constant.Goes for about $60.Just a thought :?

damn dude....you're pretty smart. seriously. I never gave that stuff much thought. I hate wiring.

olds48
04-27-2008, 03:27 PM
It's what I do for a livin' :D They made me learn it :(

Tod74
04-27-2008, 04:23 PM
It's what I do for a livin' :D They made me learn it :(

yeah you better know what your do'n when working on someone's house !! :lol:

olds48
04-28-2008, 08:39 PM
:D :D :D