Results 1 to 4 of 4

Thread: Valve seals riding up on valve

  1. #1
    Junior Member JOURNEYMAN
    Join Date
    Oct 2007
    Location
    Las Cruces, NM
    Posts
    29

    Valve seals riding up on valve

    We have a set of (BBC aluminum) Dart heads with 15 passes since Dart replaced one head and put new valves and got the other head to new specs. We have a problem with the valve seals riding up on the valves, they are the blue ones with the tiny springs that go around the stem in the seal. Don't know if it is the wrong seal or if the springs are messed up or what. All but about 4 valves have this problem. The heads being new they are not leaking oil but the little springs are getting down in the pan. Before I take them to our head guy, has anyone had this issue? I am calling Dart also, but I am worried something is not right.

    Rick

  2. #2
    Senior Member RACING JUNKIE
    Join Date
    Sep 2007
    Location
    Montvale, VA
    Posts
    1,431
    It sure doesn't sound right. It sounds like maybe the seals are not gripping the valve guides tight enough,they are usually pretty tough to pop on.Tight to the point that if you ever pull one off you wouldn't want to reuse it. Is it a possibility the seals are for another diameter valve stem? They still shouldn't be so tight as to jerk the seals off of the guides. Any witness marks to suggest a spring is snagging them?Hard to imagine 12 springs snagging seals,though. Very odd. Keep us posted on what you discover,please!
    "The problem with quotes on the Internet is that you cannot confirm their validity"- Abraham Lincoln

  3. #3
    Senior Member RACING JUNKIE
    Join Date
    Dec 2008
    Location
    Sugar Hill, GA
    Posts
    1,365
    x2 Olds
    It sounds like .531 ID seals on .500 OD guides.
    Dave
    http://www.racingjunk.com/profile/343797
    "All that is necessary for the triump of evil is for good men to do nothing" Edmund Burke

  4. #4
    Junior Member JOURNEYMAN
    Join Date
    Oct 2007
    Location
    Las Cruces, NM
    Posts
    29
    Quote Originally Posted by olds48
    It sure doesn't sound right. It sounds like maybe the seals are not gripping the valve guides tight enough,they are usually pretty tough to pop on.Tight to the point that if you ever pull one off you wouldn't want to reuse it. Is it a possibility the seals are for another diameter valve stem? They still shouldn't be so tight as to jerk the seals off of the guides. Any witness marks to suggest a spring is snagging them?Hard to imagine 12 springs snagging seals,though. Very odd. Keep us posted on what you discover,please!
    I will keep you posted, we have a real good head guy here in this little town and he is fixing the problem and I will quiz him on it.

    Rick


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy