Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: throwing belts off my BBC HELP

  1. #1
    Senior Member DYNO OPERATOR bixblk's Avatar
    Join Date
    Dec 2004
    Location
    Chicagoland area
    Posts
    472

    throwing belts off my BBC HELP

    Hello guys
    Coming here for advice (again)
    I am having a problem keeping belts on my 70 chevelle BBC
    here are the details
    I have checked alignment (x10)
    It started doing it with the last 496 after it was making alot of power,(gm block)
    I have installed
    new 540 in BBC motor (Merlin block) not because of the belt issue ?
    new water pump
    new brackets and have tried a couple different brackets
    had v grove pulley system, changed that to a gilmer kit with a 42 in belt
    That kit has the notched (tooth) wider pullies that mount on the crank waterpump and alt, I am using the v groove for the power steering.It stays on
    The problem seems to happen when I wack it on the street and the tires break loose. or possibly when shifting. I do not know exactly when it comes off during driving. You can give it small revs while watching it and it does not move at all stays strait, but if you take it for a ride and wack it while driving it seems to come off. I realize these are strechy details but it has frustrated me and starting to piss me off. some good friends of mine have looked at it also still no go.
    should I go to an electric pump and belt only to the alt
    any help would be great
    jeff 708-308-0282
    I know sometimes the simple things get to be big issues, am I missing something ?
    I have been doing this awhile 30 years and maybe some new ideas may help.
    As I reread this it seems like I am stupid, but honestly I have checked and rechecked this set up and the last set up a bunch of times, this motor and the last make about 800 HP .
    What going on ?
    Call or reply
    Jeff :( 708-308-0282

  2. #2
    Senior Member RACING JUNKIE
    Join Date
    Jan 2006
    Location
    La.
    Posts
    2,890
    It sounds like, one or more of your pullys are on an angle, i realize you've checked front to back for lineup, but maybe one of the pullys is not square/ parellel to the others, causing the belt to walk.
    Just a guess?

    Zip.

  3. #3
    Senior Member DYNO OPERATOR bixblk's Avatar
    Join Date
    Dec 2004
    Location
    Chicagoland area
    Posts
    472

    zip

    Thanks Zip
    I am going to check that, it has to be something like a geometry issue, not square to each other or parallel, I had another set of eyes look at it and they thought it still looked a little cocked or not parallel,I am going to figure this son of a gun out, thanks jeff

  4. #4
    Senior Member RACING JUNKIE
    Join Date
    Mar 2003
    Location
    Fountain,MICHIGAN
    Posts
    856

    ?

    Have YOU Installed a LARGE Pulley on the Alt.so its SLOWED Down?When the Alt.Starts to Make Power You NEED the LARGE Pulley when the Motot Goes over 6000!
    You WILL Be Surprised what this does!!!
    Later
    G 8)

  5. #5
    Senior Member DYNO OPERATOR bixblk's Avatar
    Join Date
    Dec 2004
    Location
    Chicagoland area
    Posts
    472

    kit

    I used the gilmer kit out of the box ? What can happen , it is funny you say that my tach is not working properly now ? coincedence ?

  6. #6
    Senior Member DYNO OPERATOR bixblk's Avatar
    Join Date
    Dec 2004
    Location
    Chicagoland area
    Posts
    472

    update

    Still throwing belts, so I put an electric pump and fan on the car. Removed the alt belt and power steering belt to put down some passes on saturday.
    I did find a billet set up for the alternator, I will try it when it comes.
    Looking forward to see what this 540 that Nyes built will do in my chevelle
    Jeff

  7. #7
    Senior Member DYNO OPERATOR bixblk's Avatar
    Join Date
    Dec 2004
    Location
    Chicagoland area
    Posts
    472

    Nyes 540

    Follow up
    fastest the car ever went, put the car 3.5 feet in the air, and my leg is stilled cramped up from putting it against the cage trying to steer it ?????
    What a rush !!!!!
    drove the car w/o an alt belt today brackets coming

  8. #8
    Senior Member RACING JUNKIE
    Join Date
    Nov 2008
    Location
    Niagara Falls, NY
    Posts
    965

    Re: Nyes 540

    Quote Originally Posted by bixblk
    Follow up
    fastest the car ever went, put the car 3.5 feet in the air, and my leg is stilled cramped up from putting it against the cage trying to steer it ?????
    What a rush !!!!!
    drove the car w/o an alt belt today brackets coming
    sounds like fun :wink:
    GOOD PARTS AREN'T CHEAP AND CHEAP PARTS ARE NEVER GOOD.........
    http://img.photobucket.com/albums/v2...lastscan-3.jpg

  9. #9
    Senior Member DYNO OPERATOR bixblk's Avatar
    Join Date
    Dec 2004
    Location
    Chicagoland area
    Posts
    472

    rush

    you know it was a ride when the photographer asks you to alert her when you are running next so she can get another picture of the wheel stand, she told me "nice wheelie" FYI street car, stock appearing suspension, full frame, roll bar all the interior, 10.5 tire, BBC no spray, in race gear,3660 lbs, pointing towards the sky, looks like I will not need to replace the front tires for awhile

    Oh yea..Also I set the front wheels down like a butterfly with tender feet ?

  10. #10
    Member CRAFTSMAN
    Join Date
    Jan 2011
    Location
    TEXAS
    Posts
    50
    Dude get those pics from her and post them....I wanna see


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy