Results 1 to 4 of 4

Thread: Chevy truck issues

  1. #1

    Chevy truck issues

    Ok, 89 1500 sierra. 305, 5 speed.

    starts fine, idles fine. when I drive it cold, it wants to die out, but runs like new when it's warm. new temp sensor on intake, rebuilt distributor, new battery and cables. throws egr code, but it doesnt have cat on exhaust. all vacuum lines look good, but haven't had a chance to check if there are vac lines on tranny.

    Can anyone help?

  2. #2
    Senior Member DYNO OPERATOR
    Join Date
    Aug 2007
    Location
    Lost Creek, WV
    Posts
    533
    First thing I would do is check fuel pressure and delivery. It could be low.

    TS1955

  3. #3
    Senior Member RACING JUNKIE
    Join Date
    Apr 2009
    Location
    kingsport tn
    Posts
    1,735
    egr valve throttle position sensor map/mas sensor
    CRIMEDOG
    Sam Wood

  4. #4
    Junior Member APPRENTICE
    Join Date
    Mar 2007
    Posts
    16
    If it's got an electronic EGR on the front of the intake, take it off (2 x 10MM Bolts) and clean it out with carb cleaner. Most likely got a chunk of carbon keeping the diaphram open. If that doesn't do it and you can't find another vacuum leak, check the thottle position sensor.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy