Results 1 to 3 of 3

Thread: turbo 400 trany brake dont hold

  1. #1
    Senior Member MASTER BUILDER
    Join Date
    Mar 2008
    Posts
    173

    turbo 400 trany brake dont hold

    have 67 nove with a 540 horse sbc engine and every so often(when tranny gets hot if i have tranny brake on a little too long)) the car pulls through the tranny brake and i red light. tranny is a little old. sonenoid is fairly new. any idea why this happens? i have a tranny cooler that is cooled by a fan. this has happened a few times over the past year thanks art PS tranny is a turbo 400 with a 3200 -3600 stall converter

  2. #2
    Senior Member RACING JUNKIE
    Join Date
    Dec 2004
    Location
    austin texas
    Posts
    729
    Sounds like its ready for a rebuild. low or reverse seals are weak and one is overpowering the other when you old it a too long

  3. #3
    Senior Member MASTER BUILDER
    Join Date
    Mar 2008
    Posts
    173

    tranny

    thanks kwk you are more than right when you say its time for a rebuild art

  4. Racing Junk


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy