Results 1 to 3 of 3

Thread: comp cams viton valve seals

  1. #1
    Junior Member SHOW GUEST
    Join Date
    Oct 2007
    Posts
    2

    comp cams viton valve seals

    I have viton valve seals on all valves. It is a 565 with 14.9 to 1. and triple springs. I have found pieces of the seals in my oil filter and in my pan. I removed the valve covers and noticed most of the exaust valve seals are gone and alot of the intakes are off the guide sliding up. I am not sure what to do now. Since the metal from the seals has gone through the motor I am going to pull it and freshen it up. But do I go with no seals or just on the intake..................Heads are Brodix bb2x Not sure what to do . Anyone have this problem ?

  2. #2
    Senior Member RACING JUNKIE TheYellaBrick's Avatar
    Join Date
    Mar 2008
    Location
    Emmett, Idaho
    Posts
    7,334
    Sounds like the retainers are crushing them to bits. Check for clearance at full valve open.
    TRUTH is HATE
    to those who
    HATE TRUTH

    God Bless our folks in uniform
    "We the People, have your backs"
    http://www.racingjunk.com/profile/279898

  3. #3
    Senior Member RACING JUNKIE
    Join Date
    Sep 2007
    Posts
    4,143
    Quote Originally Posted by DrivingMissDD
    Sounds like the retainers are crushing them to bits. Check for clearance at full valve open.
    I agree.


    P.S. You don't need seals on the exhaust.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy