Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Another Filter Question

  1. #1
    Member JUNIOR BUILDER
    Join Date
    Jun 2009
    Location
    New Richmond, WI.
    Posts
    87

    Another Filter Question

    Here a couple months ago i lost my lil 3.8L ford in my mustang. After lookin around i seen that the oil filter o ring blew out ran her out of oil in a heart beat and so on. I had a WIX on there. Later that day i bought some cheap oil and a filter and fired it back up. Made some nasty noises haha but it didnt take 5 seconds befor i had a puddle of oil on the ground. Pulled the filter off same thing blew the o ring out.What could have happened to cause it to be pushin out the oil filter o rings?
    Follow No One
    Built With Tools Not Chopsticks

  2. #2
    Senior Member RACING JUNKIE DirkaDirka's Avatar
    Join Date
    Jul 2009
    Location
    Clarksville, TN
    Posts
    1,954
    Too much oil pressure maybe??
    Its all fun and games till someone loses a nut!

    http://www.racingjunk.com/profile/400466

  3. #3
    Senior Member RACING JUNKIE mopar1968's Avatar
    Join Date
    Dec 2006
    Location
    Abingdon,Virginia
    Posts
    3,579
    Bypass valve stuck open in oil pump, sludge build up :!: :!:



    ''JUST MY TWO CENT'S WORTH''
    Head's up the true drag race!!

  4. #4
    Senior Member RACING JUNKIE TheYellaBrick's Avatar
    Join Date
    Mar 2008
    Location
    Emmett, Idaho
    Posts
    7,334

    X2
    TRUTH is HATE
    to those who
    HATE TRUTH

    God Bless our folks in uniform
    "We the People, have your backs"
    http://www.racingjunk.com/profile/279898

  5. #5
    Senior Member RACING JUNKIE
    Join Date
    Mar 2008
    Location
    falkville al
    Posts
    1,766
    sidin with mpoar on this one. also im sure you know how to put a filter on but ive seen it bunches of times and by guys who know what their doing. tightening then too tight?

  6. #6
    Senior Member RACING JUNKIE
    Join Date
    Jul 2007
    Location
    Independence, Missouri
    Posts
    1,188
    <----This one pegs the gauge(100+psi) at wot. It doesn't leak or blow past the o-ring. I don't think it's pressure alone. If you're getting the filter on too tight, it will tho'. My Filter bypass is blocked, so all oil goes thru the filter.
    No matter where you go, there you are.
    **IN GOD WE TRUST**

  7. #7
    Administrator RACING JUNKIE bjuice's Avatar
    Join Date
    Apr 2003
    Location
    Greenville s.c.
    Posts
    3,239
    the By pass is 1st thought..i see your from WI...very cold up there now...what weight oil do you use ?..i think your following what i am saying here
    Bjuice..

    "I'M YOUR HUCKLEBERRY ! "

  8. #8
    Senior Member RACING JUNKIE curtisreed's Avatar
    Join Date
    Feb 2004
    Location
    KIEFER, OK.
    Posts
    1,309
    I would think if the bypass were stuck open it would not build pressure that high. Maybe stuck closed?

    Curtis

  9. #9
    Senior Member RACING JUNKIE fla1976's Avatar
    Join Date
    Aug 2007
    Posts
    1,527

    filter

    Did you check to make sure the old "O" ring was completely removed?

  10. #10
    Senior Member DYNO OPERATOR
    Join Date
    Aug 2007
    Location
    Lost Creek, WV
    Posts
    533
    I agree with fla1976 on this...those O-rings are recessed in a groove in the filter. In order to "blow" one out it would have to be double stacked.
    JMO!

    TS1955


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy