Results 1 to 2 of 2

Thread: SBC oil problem

  1. #1
    Senior Member RACING JUNKIE
    Join Date
    Dec 2004
    Location
    austin texas
    Posts
    729

    SBC oil problem

    Has anyone else ever experienced this? i built a stock 350 sbc, hydraulic roller cam, all crank and rods had proper clearance, new cam bearings, new screw in oil galley plugs front and rear and they are not in to far and flawlessly clean. When i primed the engine, i could not get no oil out of the pass side head rockers? Number 1 cylinder had oil squirting out and most of the driver side had oil flowing out, i backed all the rockers off the pass side, it slowly started flowing out a few rockers on the pass side, i swapped the brand new lifters around to different bores and same thing. i pulled several lifters out of the pass side and i could feel plenty of oil pressure on the galley, i was rotating the crank while priming, i also let it set there and prime. I use a old distributor for priming. This is the only sbc i have ever noticed this problem with?

    I started it up and it sounded like the lifters had bled down, after just a min the noise all went away and i drove it no problem.

  2. #2
    Senior Member MASTER BUILDER
    Join Date
    Dec 2004
    Location
    out of my mind in Kalamazoo, MI
    Posts
    179
    What were you using to spin the primer....a cordless or an electric drill motor will only spin so fast.... I could only muster about 10-15 lbs on my electric drill...just need to get oil to the lifter valley...


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy