Results 1 to 7 of 7

Thread: front end shake

  1. #1

    front end shake

    i have a 87 camaro the car drives good but after a wheels up launch car goes into bad front end shake. anybody experience this problem with there car if so what did you do to fix the problem thanks.

  2. #2
    have anyone install steering dampers on there car and did they help.

  3. #3
    Senior Member RACING JUNKIE fla1976's Avatar
    Join Date
    Aug 2007
    Posts
    1,527

    Shake

    Have you checked front wheel bearings, tie rod ends, center link and ball joints? What about the shocks? Have you tried different wheels and tires? Is the alignment within specs? Has the car always done this or is it a recent problem? Has the frame been damaged? Is the front end tied to the rest of the car with the cage?
    Just some things to start with.

  4. #4
    no it recent problem i have check all the front end parts looks good and thigh but it just started doing this, it's got me puzzle man.

  5. #5
    Senior Member RACING JUNKIE
    Join Date
    Sep 2007
    Location
    orland pk il
    Posts
    2,429
    upper & lower control arm bushings?

  6. #6
    only have lower and they'er thigh.

  7. #7
    Senior Member RACING JUNKIE
    Join Date
    Sep 2007
    Location
    orland pk il
    Posts
    2,429
    oops didn't catch year of car ops: ops:


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy