Results 1 to 9 of 9

Thread: truck will not run right

  1. #1
    Member JUNIOR BUILDER
    Join Date
    Jun 2009
    Location
    New Richmond, WI.
    Posts
    87

    truck will not run right

    i have a 99 chevy silerado half ton with the 4.8L.
    it fires and idles jsut fine dont miss a beat but one you get it up to about 2000rpm it starts spittin. i stole the tech 2 GM. computre from work and it dont throw any codes. other than a misfire when we get to that rpm range. me and these new motors dont get alone real well and im not real sure where to even start.

  2. #2
    Senior Member RACING JUNKIE mopar1968's Avatar
    Join Date
    Dec 2006
    Location
    Abingdon,Virginia
    Posts
    3,579
    What is fuel pressure @ 2000 rpm? How many miles on it?


    ''JUST MY TWO CENT'S WORTH''
    Head's up the true drag race!!

  3. #3
    Member JUNIOR BUILDER
    Join Date
    Jun 2009
    Location
    New Richmond, WI.
    Posts
    87
    shit i dotn remeber i had the g.m. tech here at work take a look at the comptuer when i brought the tech 2. back and everythign looked normal to him he said. its got about 140000 i jsut put a new fuel pump in it about 5000 miles ago 2

  4. #4
    Senior Member RACING JUNKIE mytmouz's Avatar
    Join Date
    May 2006
    Location
    Pelahatchie, MS
    Posts
    980
    Fuel pump...
    If you think nobody cares, try missing a payment...

  5. #5
    Member JUNIOR BUILDER
    Join Date
    Jun 2009
    Location
    New Richmond, WI.
    Posts
    87
    thats what i keep thinking but hell i dont wana do that again shit

  6. #6
    Senior Member RACING JUNKIE mopar1968's Avatar
    Join Date
    Dec 2006
    Location
    Abingdon,Virginia
    Posts
    3,579
    Sorry But i agree -- PUMP-- Starving for fuel.


    ''JUST MY TWO CENT'S WORTH''
    Head's up the true drag race!!

  7. #7
    Senior Member RACING JUNKIE
    Join Date
    Mar 2006
    Location
    EUGENE,OR.
    Posts
    3,408
    No codes... that is what leads me to believe what others are saying. Otherwise, you could blame it on a few sensors such as a CPS or something.
    "I would walk through hell on Sunday before I fear the enemy"

  8. #8
    Senior Member DYNO OPERATOR
    Join Date
    Mar 2008
    Location
    New Orleans,La
    Posts
    515
    99 with 4.8 L should be new body style it needs 60psi to run if you aint got it ,it aint gonna run.
    Full Time Racing,WASTED $$ division

    http://www.racingjunk.com/profile/281924

    Be a Fan of Full Time Racing on facebook http://www.facebook.com/pages/FULL-T...G/177402183154

  9. #9
    Member JUNIOR BUILDER
    Join Date
    Jun 2009
    Location
    New Richmond, WI.
    Posts
    87
    thanks guys i did some digin and the pump is still warenty so im goin take a weeknd off of racing(sadly enough but dont get anythign done with racing on the brain during the weeknd) and jsut get that finished been blowing it off to race all wekkend for to long now


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy