Results 1 to 6 of 6

Thread: Frame mounts?

  1. #1
    Senior Member MASTER BUILDER
    Join Date
    Jun 2007
    Location
    FayettevilleN.C.
    Posts
    215

    Frame mounts?

    I found out that motor mounts were possibly switched.I removed them and switched sides and it appears to be wrong.All holes line up but mounts seem to be hanging over crossmember excessively.These are sbc motor mounts in a 68 Firebird.Is it possible these are wrong mounts? Was old i need 68 Camaro mounts,but not sure if these are specifically for camaro as they were mounted to frame already when i got this car.Please look at pictures and tell me if anyone knows if this looks right an if it will work.Thanks,Randy.[img][/img]

  2. #2
    Senior Member MASTER BUILDER
    Join Date
    Jun 2007
    Location
    FayettevilleN.C.
    Posts
    215
    Somedy!I NEED HELP! LOL.Ill check tomorrow.

  3. #3
    Senior Member RACING JUNKIE fla1976's Avatar
    Join Date
    Aug 2007
    Posts
    1,527

    Mounts

    Here is a photo of the motor mount in my 52 Chevy. It is a 69 Camaro subframe and it looks pretty much like your setup. So, we are either both right or both wrong. ops:

    If you click on it it will enlarge the photo.





  4. #4
    Senior Member MASTER BUILDER
    Join Date
    Jun 2007
    Location
    FayettevilleN.C.
    Posts
    215
    Thats exactly how mine looks.It just seems to hangover excessively.Hopefully it wont give under a load.Thanks alot for your reply.It does help to know its not just me.LOL.

  5. #5
    Senior Member DYNO OPERATOR
    Join Date
    Feb 2009
    Posts
    510
    Nope not right. Oh wait, you have a Chevy motor in a Pontiac? haha. My buddy's 68 Camaro looks like this, I would live with it.


    Just wondering why you don't have a Pontiac motor in it?

  6. #6
    Senior Member MASTER BUILDER
    Join Date
    Jun 2007
    Location
    FayettevilleN.C.
    Posts
    215
    Quote Originally Posted by CamBirdRacing
    Nope not right. Oh wait, you have a Chevy motor in a Pontiac? haha. My buddy's 68 Camaro looks like this, I would live with it.


    Just wondering why you don't have a Pontiac motor in it?
    I answered this question in another post a while back. Posted: Thu Apr 02, 2009 1:24 am Post subject:

    --------------------------------------------------------------------------------

    Posted: Thu Apr 02, 2009 1:24 am Subject: PICS:CamBirdRacing wrote:
    Be nice when you get it done, but G.M. never put a Chevy motor in a Pontiac in 1968. Sorry about that, I'm just a big Pontiac fan.hotrod1024 wrote:
    I am very aware gm never put a Chevy motor in a Pontiac.Ford didnt put Chevy motors in their cars either, but I see them all the time. My bird came with a Chevy motor when I got it,so I decided not to change a good thing.Especially when i dont have money to buy a Pontiac motor and trans back in it.I work with what I got,which seems fine to me.Im a Pontiac fan to,but also Chevy,so why not combine 2 things I like.LOL.Thanks for comments guys.
    _________________


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy