Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: ran into another problem

  1. #1
    Senior Member EXPERT BUILDER
    Join Date
    Nov 2008
    Posts
    263

    ran into another problem

    ok so now my truck is makin another wierd knock
    but it almost sounds like the trans
    it will not do it in park or neutral no matter how high it gets revved
    and it only knocks when im slowing down wether it be coasting or braking
    and it stops once the trans dropps to first
    i looked at the trans fluid level to see and it was low so i added a half a quart of trans fluid cus it was all i had, it was till about a quart low at this point
    it has a leak from the dipstick as well

    please help out

  2. #2
    Senior Member MASTER BUILDER
    Join Date
    Dec 2004
    Location
    out of my mind in Kalamazoo, MI
    Posts
    179
    bowhay....top it off and see if the noise goes away...could be a flywheel or it could be the front pump in the trans....sounds like it might be the pump....but wont know until it is topped off.

  3. #3
    Senior Member RACING JUNKIE
    Join Date
    May 2006
    Posts
    2,044
    Check your torque convertor bolts.
    ***IN GOD WE TRUST***

  4. #4
    Senior Member RACING JUNKIE
    Join Date
    Sep 2007
    Posts
    4,143
    Quote Originally Posted by cepx111
    Check your torque convertor bolts.
    yup...it will sound like the mains are hammering if they are loose.

    But you could have hurt the bearings with that deal you went through before.

  5. #5
    Senior Member EXPERT BUILDER
    Join Date
    Nov 2008
    Posts
    263
    idk
    i checked the bearings when the motor was out and thats not it

  6. #6
    Senior Member RACING JUNKIE
    Join Date
    Dec 2007
    Location
    ohio
    Posts
    810
    bowhay this may sound crazy, but you may want to check the alternator, i had a bearing go bad in one, it sounded like all the bad stuff... wrist pin bearings etc, just something to check, good luck.

  7. #7
    Senior Member EXPERT BUILDER
    Join Date
    Nov 2008
    Posts
    263
    how exactly would u go about checking the alternator for that

  8. #8
    Senior Member RACING JUNKIE
    Join Date
    Dec 2007
    Location
    ohio
    Posts
    810
    take the belt off, or use a ( hose-a-scope) a peice garden hose from the ear aimed toward the alternator, i did both, only in reverse.

  9. #9
    Senior Member RACING JUNKIE curtisreed's Avatar
    Join Date
    Feb 2004
    Location
    KIEFER, OK.
    Posts
    1,309
    Quote Originally Posted by itsabird
    take the belt off, or use a ( hose-a-scope) a peice garden hose from the ear aimed toward the alternator, i did both, only in reverse.
    You can also use a long wooden handled screw driver with the metal end on the part in question and put your ear on the handle end. Works great.

    I like the hose-a-scope deal.


    Curtis

  10. #10
    Junior Member SHOW GUEST
    Join Date
    Mar 2009
    Posts
    8
    i had a flywheel cracked that did the same thing.....almost pulled the motor but checked that first.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy