Results 1 to 8 of 8

Thread: 1150 fueling troubles

  1. #1
    Junior Member APPRENTICE
    Join Date
    Mar 2004
    Location
    Gatesville Texas
    Posts
    13

    1150 fueling troubles

    My carb is dumping alot of fuel from the boosters into the intake at idle and up, I know there should be some but she loading up bad.
    I pulled it apart and did find alittle trash but not much all else looked fine.
    Any ideas this thing has me stumped.

    Thanks

  2. #2
    Senior Member RACING JUNKIE mopar1968's Avatar
    Join Date
    Dec 2006
    Location
    Abingdon,Virginia
    Posts
    3,579
    How is your needles & seat's looking? what fuel pressure are you running?
    Head's up the true drag race!!

  3. #3
    Junior Member APPRENTICE
    Join Date
    Mar 2004
    Location
    Gatesville Texas
    Posts
    13
    All looked good, holds steady level in the sight hole < I set them just at the bottom of the holes, running 8 psi at the carb and 18 at the pump.
    Has a aeromotive drag pump, carb is a quickfuel 1150 Dom annular boosters.

  4. #4
    Senior Member RACING JUNKIE
    Join Date
    Jun 2003
    Location
    Hobbs, NM
    Posts
    842
    Turn your pressure down to 7psi. Ive seen some carbs actually spraying some fuel into the vent on your fuel block from the needle seat, causing excessive fuel to come out of the boosters. But 99% of the time its your needle seats not holding.

  5. #5
    Junior Member SHOW GUEST
    Join Date
    Aug 2008
    Posts
    6
    If fuel is dripping out of the boosters at idle, and your float levels at in the middle of the glass you either have your butterflies open too far, or there is some dirt in the carburetor itself.

  6. #6
    Junior Member APPRENTICE
    Join Date
    Mar 2004
    Location
    Gatesville Texas
    Posts
    13
    I ordered new needle and seats today .130 and its possible there is trash in there. I bought some VP fuel from a local dealer and found what looked like flower in it a few days after , I swear it didnt look like that when I got it ,but I caught it at the track we drained everything and replaced it.
    Might have whatever that was hidden in the carb somewhere so I will pull it down and clean the crap out of it and try again.

    thanks yall I will let yall know

  7. #7
    Senior Member RACING JUNKIE mopar1968's Avatar
    Join Date
    Dec 2006
    Location
    Abingdon,Virginia
    Posts
    3,579
    I run a dominator @ 7psi, i believe 8 psi will over come the seat's.
    Head's up the true drag race!!

  8. #8
    Senior Member DYNO OPERATOR
    Join Date
    Aug 2005
    Location
    Rifle Colorado
    Posts
    585
    I have to agree with Carbguy on this one. I'll bet the throttle blades are open too far @idle, uncovering the transfer slots, and pulling fuel through the boosters. Try backing out idle speed screw until the boosters quit dripping, then readjust idle mix. You'll probably have to slow idle speed down after mix adjustment. I had the same problem a few years back and it ran me nuts! It turned out to be just that simple.....


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy