Results 1 to 7 of 7

Thread: Water in Head??

  1. #1
    Senior Member MASTER BUILDER
    Join Date
    Feb 2008
    Location
    New Jersey
    Posts
    133

    Water in Head??

    I dyno'd my motor last week. I have it in the garage with the bag over it. Tonight i removed a valve cover to install different valve cover gaskets and noticed small area's of clear looking water.. in a few low areas of the head. It doesnt look like a milkshake... is this just condensation or should i be worried.. the other head didnt look exactly the same. If the dyno was using just water would it look clear if there was some kind of leak??

    thanks
    Keith

  2. #2
    Senior Member RACING JUNKIE
    Join Date
    Jan 2006
    Location
    La.
    Posts
    2,890
    Could be condensation, where i live it's so humid if you cover a motor with plastic, the next day every thing is rusted, even in the summer, i've got 2 blks right now that i have to clean or revat, from storing them in my shop over the winter.
    Do a pressure test on the cooling system, if there is no leakdown, it's probably condensation.

    JMO

    Zip.

  3. #3
    Senior Member MASTER BUILDER
    Join Date
    Feb 2008
    Location
    New Jersey
    Posts
    133

    water in head

    I wish i could pressure test it... i havent installed it into the car yet since last weeks dyno session

  4. #4
    Senior Member RACING JUNKIE
    Join Date
    Sep 2007
    Posts
    4,143
    Quote Originally Posted by dynaguy03
    I wish i could pressure test it... i havent installed it into the car yet since last weeks dyno session
    it does not need to be installed tp preasure test it. just hook the hoses to a radiator that don't leak sitting in the floor or fabricate a tube that will accept the cap/tester and loop the water pump to the thermostat housing.

    Pull the drain plug and watch it drain...If there is water in the oil it will come out first

  5. #5
    Senior Member RACING JUNKIE
    Join Date
    Dec 2004
    Location
    austin texas
    Posts
    729
    Does the engine have head studs or bolts?

  6. #6
    Senior Member MASTER BUILDER
    Join Date
    Feb 2008
    Location
    New Jersey
    Posts
    133

    KW...

    KW. i have heads studs no bolts...

  7. #7
    Senior Member RACING JUNKIE
    Join Date
    Dec 2004
    Location
    austin texas
    Posts
    729
    are they leaking inside the heads? Maybe thats were this lil bit of water came from, i know they are bad about getting them to seal even when a good coat of sealer is applied. Just a thought. goodluck!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy