Results 1 to 1 of 1

Thread: c4 problem ????????????? need some help

  1. #1
    Senior Member SENIOR BUILDER
    Join Date
    Mar 2004
    Location
    XENIA OHIO 45385
    Posts
    107

    c4 problem ????????????? need some help

    i have a fox body mustang with a new [few weeks old] c4 transmission 2500 stall . just got car seen dated video of car running a 11.47 on and off the gas [could see shift light]at the big end. now,,,,, i have the car. at cold starts no response [ whatsoever] until it hits about 3000 rpm's. driving cold only first gear as it warms up ill get second gear then even 3rd when up to temp. by the dip stick was a bit over full, but it acted to me as if fluid was low??? [ possible wrong dip stick?] so i added a quart ran car at idle let cool off the same thing as before. the guy the car came from was surprised when i told him [ i trust this guy 100 percent] this has me baffeled. i dont want to pull it until i can somehow have an idea whats wrong? now i would guess 'if taken to the track' and ran at 'all out' this may just shift and run fine at high rpm. i have had many cars with stalls 2500 to 5500 this is not the stall working. when this trans engages its like side stepping a clutch, and reverse is same way. help help help call 937-768-0523 for eddie or leave me a message here ill be on vacation from wed til sat thank you eddie :?:

  2. Racing Junk


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy