Results 1 to 3 of 3

Thread: 355 tbi-not running right-go to carb set up?

  1. #1

    355 tbi-not running right-go to carb set up?

    I have a chevy 355 tbi,420-442 cam,holley 670 tbi,hot chip,400 turbo tranny,373 posi.Runs great up to 3000 rpm,then it starts breaking up.Everything is new,dist,wires,fuel pump,tbi,plugs,engine.Anybody got a suggestion other than a dyno?

  2. #2
    Junior Member SHOW GUEST
    Join Date
    Mar 2005
    Posts
    4
    have you checked valve spring pressure. many people will overlook that and think there is a ignition problem. I have a 421 sbc with a tbi unit on it and it runs great. dynoed to the ground 311 hp and 362 trq. Dont give up it will be worth it in the end. you may want to call tom at throttle body specialties or at turbo city.


    steve

  3. #3
    Senior Member DYNO OPERATOR
    Join Date
    Feb 2006
    Location
    VA Hospital, Dallas, Tx (214 302 1924) cell-972-464-7400
    Posts
    540
    You will regret giving up the EFI. Check fuel presure, fuel filter, all named above and by then your problem should be found.

    Ed
    " Let all things that hath breath, praise the Lord. Praise Ye the Lord" Psalms 150 vs 6.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy