Results 1 to 2 of 2

Thread: 8896 Problem

  1. #1

    8896 Problem

    I have a 509 bbc roller motor with an 8896 out of the box and I can't get it to run good enough to tune. Sometimes the front pump nozzles work and sometimes they don't. I can get it to run smooth until I get on it and then it starts running bad again, cutting out between 2 & 5 thousand rpms. It responds real good at wot running 8 psi airbleeds out around 1 1/4. Any help would be great. Thanks.

  2. #2
    Senior Member RACING JUNKIE jmarksdragster's Avatar
    Join Date
    Jul 2007
    Location
    Florida
    Posts
    635
    Here we go again. I have an 8896 1050 that had some issues like yours. I also bought a used 1250 to convert the same as you need to do, most likely not a pump issue but an excessively rich mid. I have made mods to my 1050 as well. Read the following and you will understand this is a common Dominator problem.

    http://speedtalk.com/forum/viewtopic.php?t=9934
    http://www.motorsportsvillage.com/fo...pic.php?t=3283
    http://www.motorsportsvillage.com/fo...pic.php?t=3742
    http://www.motorsportsvillage.com/fo...pic.php?t=3811


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy