Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Blown EGT TEMP HELP

  1. #1

    Blown EGT TEMP HELP

    I have a blown 8_71 SBC it has :
    Callies crank
    oliver rods
    venolia blower 7.5-1 pistons
    comp solid roller .575 roller cam
    gm alum bowtie heads fully ported
    weiand 8-71 blower with factory pulley set up
    twin holley 750 carbs jetted 73 front and 80 rear
    msd dig 6 full msd everything else

    My question is while street driving the car the EGT temps rise to over 1200 almost hit 1300 . the probe is in the # 2 exhaust in the center of the header about 3" from exhaust flange. if i let off the gas the egt goes down. to about 1000 and car runs good. while cruising about 2300-2600 the egt climbs up rapidly and car pops thru exhaust . only while egt is high timing is set at a locked out 30* i have tried 28* and still the same. plugs look like right mixture.
    any help is much appreciated and i thank you in advance

  2. #2
    Member JUNIOR BUILDER
    Join Date
    Nov 2004
    Location
    Home of Bill and Ted
    Posts
    92
    It's running lean at cruise. What's your vacuum reading at that RPM? You could jet up on your primaries and/or play with the power valve. Are your carbs mounted sideways? Do you run a 1:1 linkage on your primary/secondaries? What are you running for fuel?

    You said, "factory pulleys." What drive are you running , 1/2" or 8mm? And what is the tooth count on each of the pulleys.

    Does it idle ok? If you're driving it on the street why do you have the timing locked out? I know others are going to disagree, but I'm a fan of using one blue and one silver spring and not locking it out.
    The show queen gets crowned...6.32@111

  3. #3
    Senior Member RACING JUNKIE
    Join Date
    Sep 2007
    Location
    Belleville, IL
    Posts
    658
    Up those front jets to 80s. Fat is good.

  4. #4
    Member JUNIOR BUILDER
    Join Date
    Nov 2004
    Location
    Home of Bill and Ted
    Posts
    92
    Quote Originally Posted by OneBadGMC
    Fat is good.
    Plugs are cheaper than pistons!
    The show queen gets crowned...6.32@111

  5. #5
    the carbs are mounted sideways . seems rich at idle with 73 primary but lean while driving. plugs look ok but not rich. no idea on vaccuum, should i check it at idle or 2000 . boost varies when i wack the throttle it goes up but on cruise even at 3000 no boost has to hit 4000 to make it . atleast at the gauge . could be the hose. i am gonna check the blow off valve it may be leaking boost and sucking vaccuum.
    the tooth count is 63 top and 52 bottom with an 8 mm drive .
    i am gonna jet it 80 in front and 90 in rear tomorrow to see if that helps. again i think it is really lean.
    what is the optimal egt temp it should run. thanks againofr all your help in advance, justin

  6. #6
    Senior Member RACING JUNKIE
    Join Date
    Sep 2007
    Location
    Belleville, IL
    Posts
    658
    Quote Originally Posted by woodfamilyracing
    the carbs are mounted sideways . seems rich at idle with 73 primary but lean while driving. plugs look ok but not rich. no idea on vaccuum, should i check it at idle or 2000 . boost varies when i wack the throttle it goes up but on cruise even at 3000 no boost has to hit 4000 to make it . atleast at the gauge . could be the hose. i am gonna check the blow off valve it may be leaking boost and sucking vaccuum.
    the tooth count is 63 top and 52 bottom with an 8 mm drive .
    i am gonna jet it 80 in front and 90 in rear tomorrow to see if that helps. again i think it is really lean.
    what is the optimal egt temp it should run. thanks againofr all your help in advance, justin
    The idle has nothing to do with the main jet. They are on separate circuits.

    You have to tune each circuit individually.

    Idle
    Accelerator Pump
    Primary jetting (cruise)
    Secondary Pump
    Secondary Jetting (W.O.T.)

    Without taking your time and tuning each circuit, you'll chase your tail forever.

    Moving the secondary jetting up will do nothing for you unless you plan on driving wide open everywhere.

    EGT at wide open should be in the 1100F Degree realm, with mid 800s at part throttle.

  7. #7
    Member JUNIOR BUILDER
    Join Date
    Nov 2004
    Location
    Home of Bill and Ted
    Posts
    92
    Like OneBad said, take your time and do ONE THING AT A TIME!

    Leave the secondaries alone. IMO I think 80 might be a bit much for a primary jump, but then again... Maybe try a 76p/80s and see what happens. For now as long as it idles, regardless of rich, leave the idle screws alone.

    And in your situation just looking at the plugs won't tell you rich or lean. Plug reading is a learned art and best done by someone with a lot of experience.

    Your EGT sensor is a great tuning tool and will work fine. I personally use a wideband air/fuel sensor.
    The show queen gets crowned...6.32@111

  8. #8
    Senior Member RACING JUNKIE
    Join Date
    Sep 2007
    Location
    Belleville, IL
    Posts
    658
    According to the Weiand site, the blower is setup from the factory for 10-12 lbs of boost. But, of course, they don't indicate what cubic inch, because that would make sense.

    I hate to down anyone elses stuff, but man, of all the blowers out there... A Wieand? I hope you bought it more for show than power. Those blowers use reconditioned GM rotors... Good for 8 cylinder diesels, but not so good on high performance automotive.

    If you had a better blower, it would produce boost as soon as you cracked the secondaries open, regardless of RPM.

    Actually, he can read the plugs quite well. Get out on a straight stretch of a few miles, keep the throttle in one position in high gear, note the EGT and kill the ignition. Pull over and check the plug. So long as the ground strap is tan to light brown you're fine. Dark brown or black, or as is right now, grey or white, the jetting is wrong.

    The ignition timing is probably too low as well, which can also lead to high EGTs. I used to run 9.5:1 with 8 Lbs on the street (10 yrs ago or more) with 93 octane and 38 Degrees advance (locked out). I used a nitrous timing retard with a pressure switch that pulled 4 degrees out at 5 Lbs of boost. This kept the response high until the boost took over and less total ignition was required.

    You're at 2 full points of compression lower. Crank that timing up to the 34-36 range. You should see the motor respond a lot better. You'll also have to adjust carb idle down, which is probably so high right now that it's up into the transition slots rather than fully on the idle circuit.

    Shame your not in the STL Metro, I'd be happy to help tune it for you.

  9. #9
    thanks for all the help i am gonna work solely on the primaries and try to tune that. i really appreciate everyones input . i am new to the blower thing and although it is cool it is also a pain in the ass. with two carbs that is. i am gonna go work on it now thanks again i will let you know how it goes. again thanks everyone

  10. #10
    ok found the problem , it was a combination the jetting was close but the balancer spun on the crank a lil and was not reading corectly the timing mark so it was way retarded. also 2 of the spark plug boots were touching the headers and burned them cousing the pop. i corrected it drove it and egt are at 850-900 at cruise and 1150-1200 at wot . thanks t everyne that has helped. after i found the issue i decided to pull the engine and refresh it also check for detonation and good thing some of the bearings were showing some of the effect . so i plan oncorrecting this issues and having fun again.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy