Results 1 to 7 of 7

Thread: going to the races

  1. #1
    Senior Member DYNO OPERATOR
    Join Date
    Nov 2006
    Location
    NC
    Posts
    558

    going to the races

    Hi guys, got the motor (I mean engine) back in the Camaro, and got it running!!!! WOW does it sound GREAT!!!! its a 421. going racing on friday nite,or sat. nite. will post what it does!!!!! thanks,David.

  2. #2
    Senior Member RACING JUNKIE
    Join Date
    May 2003
    Location
    Coldwater, MI
    Posts
    2,998
    Good Luck and have fun !! :lol:
    David Lanning
    IHRA NHRA 387B

    Fleenor Racing Transmission
    419-280-1406
    Lanning Electric
    Complete Drag Car Wiring
    APD Race Engines
    www.apdracing.com

  3. #3
    Senior Member DYNO OPERATOR
    Join Date
    Nov 2006
    Location
    NC
    Posts
    558

    gears

    I forgot to ask what gears you think I should change to ? Im running the 6.14s from last year , there from my small engine combo Ive run in comp. elim. Ive run numbers thru richmonds charts and wonder how acturate that is?! lets see what you all think! Ill fool around this week, thanks. david.

  4. #4
    Senior Member RACING JUNKIE
    Join Date
    Jan 2006
    Location
    EastWenatchee,WA
    Posts
    887
    have fun, is there any better place to be then a dragstrip!!!!!!!!! 8)

  5. #5
    Senior Member RACING JUNKIE
    Join Date
    Sep 2005
    Location
    ID
    Posts
    1,125
    Quote Originally Posted by spib
    have fun, is there any better place to be then a dragstrip!!!!!!!!! 8)
    It's the best, except when it's 107 and no shade or A/C.

    I am still dehydrated from Friday Night...lol

    David,
    Have fun and be safe!!!!

  6. #6
    Senior Member DYNO OPERATOR
    Join Date
    May 2003
    Location
    Moscow Mills, Mo.
    Posts
    533
    Good luck with your car at the track. Looking forward to see the results.
    Sounds like your gunna have fun.

  7. #7
    Senior Member DYNO OPERATOR
    Join Date
    Nov 2006
    Location
    NC
    Posts
    558
    Well I did it good! 1st pass, launched at 4500, Tore up the rearend! the pinion was looking skyward! good thing for wheelie bars. Broke the driveshaft yoke too. New motor is an animal!!!!!!! easy fix, next time i will start from a stand still and work up to it.lol..... David.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Email us - Support@RacingJunk.com
Call us - 866.326.9227
Copyright © 2005-2016 RacingJunk.com All Rights Reserved.

Designated trademarks and brands are the property of their respective owners. Use of this Web site constitutes acceptance of the RacingJunk.com
Terms of Use, Classifieds Disclaimer, Privacy Policy, and Cookie Policy